b3f95490b9
This adds initial support for kernel 4.14 based on the patches for kernel 4.9. In the configuration I deactivated some of the new possible security features like: CONFIG_REFCOUNT_FULL CONFIG_SLAB_FREELIST_HARDENED CONFIG_SOFTLOCKUP_DETECTOR CONFIG_WARN_ALL_UNSEEDED_RANDOM And these overlay FS options are also deactivated: CONFIG_OVERLAY_FS_INDEX CONFIG_OVERLAY_FS_REDIRECT_DIR I activated this: CONFIG_FORTIFY_SOURCE CONFIG_POSIX_TIMERS CONFIG_SLAB_MERGE_DEFAULT CONFIG_WATCHDOG_HANDLE_BOOT_ENABLED I am not sure if I did the porting correct for the following patches: target/linux/generic/backport-4.14/020-backport_netfilter_rtcache.patch target/linux/generic/hack-4.14/220-gc_sections.patch target/linux/generic/hack-4.14/321-powerpc_crtsavres_prereq.patch target/linux/generic/pending-4.14/305-mips_module_reloc.patch target/linux/generic/pending-4.14/611-netfilter_match_bypass_default_table.patch target/linux/generic/pending-4.14/680-NET-skip-GRO-for-foreign-MAC-addresses.patch Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
23 lines
795 B
Diff
23 lines
795 B
Diff
From: Felix Fietkau <nbd@nbd.name>
|
|
Subject: kernel: disable MIPS VDSO by default until the cache issues have been resolved
|
|
|
|
lede-commit: 1185e645a773c86aa88cf04d0e2911dc62eb43f5
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
arch/mips/vdso/Makefile | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
--- a/arch/mips/vdso/Makefile
|
|
+++ b/arch/mips/vdso/Makefile
|
|
@@ -30,9 +30,9 @@ aflags-vdso := $(ccflags-vdso) \
|
|
ifndef CONFIG_CPU_MIPSR6
|
|
ifeq ($(call ld-ifversion, -lt, 225000000, y),y)
|
|
$(warning MIPS VDSO requires binutils >= 2.25)
|
|
- obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
|
|
- ccflags-vdso += -DDISABLE_MIPS_VDSO
|
|
endif
|
|
+ obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
|
|
+ ccflags-vdso += -DDISABLE_MIPS_VDSO
|
|
endif
|
|
|
|
# VDSO linker flags.
|