b3f95490b9
This adds initial support for kernel 4.14 based on the patches for kernel 4.9. In the configuration I deactivated some of the new possible security features like: CONFIG_REFCOUNT_FULL CONFIG_SLAB_FREELIST_HARDENED CONFIG_SOFTLOCKUP_DETECTOR CONFIG_WARN_ALL_UNSEEDED_RANDOM And these overlay FS options are also deactivated: CONFIG_OVERLAY_FS_INDEX CONFIG_OVERLAY_FS_REDIRECT_DIR I activated this: CONFIG_FORTIFY_SOURCE CONFIG_POSIX_TIMERS CONFIG_SLAB_MERGE_DEFAULT CONFIG_WATCHDOG_HANDLE_BOOT_ENABLED I am not sure if I did the porting correct for the following patches: target/linux/generic/backport-4.14/020-backport_netfilter_rtcache.patch target/linux/generic/hack-4.14/220-gc_sections.patch target/linux/generic/hack-4.14/321-powerpc_crtsavres_prereq.patch target/linux/generic/pending-4.14/305-mips_module_reloc.patch target/linux/generic/pending-4.14/611-netfilter_match_bypass_default_table.patch target/linux/generic/pending-4.14/680-NET-skip-GRO-for-foreign-MAC-addresses.patch Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
38 lines
1.3 KiB
Diff
38 lines
1.3 KiB
Diff
From 107c0964cb8db7ca28ac5199426414fdab3c274d Mon Sep 17 00:00:00 2001
|
|
From: "Alexandros C. Couloumbis" <alex@ozo.com>
|
|
Date: Fri, 7 Jul 2017 17:14:51 +0200
|
|
Subject: hack: arch: powerpc: drop register save/restore library from modules
|
|
|
|
Upstream GCC uses a libgcc function for saving/restoring registers. This
|
|
makes the code bigger, and upstream kernels need to carry that function
|
|
for every single kernel module. Our GCC is patched to avoid those
|
|
references, so we can drop the extra bloat for modules.
|
|
|
|
lede-commit: e8e1084654f50904e6bf77b70b2de3f137d7b3ec
|
|
Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
|
|
---
|
|
arch/powerpc/Makefile | 1 -
|
|
1 file changed, 1 deletion(-)
|
|
|
|
--- a/arch/powerpc/Makefile
|
|
+++ b/arch/powerpc/Makefile
|
|
@@ -59,19 +59,6 @@ machine-$(CONFIG_PPC64) += 64
|
|
machine-$(CONFIG_CPU_LITTLE_ENDIAN) += le
|
|
UTS_MACHINE := $(subst $(space),,$(machine-y))
|
|
|
|
-# XXX This needs to be before we override LD below
|
|
-ifdef CONFIG_PPC32
|
|
-KBUILD_LDFLAGS_MODULE += arch/powerpc/lib/crtsavres.o
|
|
-else
|
|
-ifeq ($(call ld-ifversion, -ge, 225000000, y),y)
|
|
-# Have the linker provide sfpr if possible.
|
|
-# There is a corresponding test in arch/powerpc/lib/Makefile
|
|
-KBUILD_LDFLAGS_MODULE += --save-restore-funcs
|
|
-else
|
|
-KBUILD_LDFLAGS_MODULE += arch/powerpc/lib/crtsavres.o
|
|
-endif
|
|
-endif
|
|
-
|
|
ifeq ($(CONFIG_CPU_LITTLE_ENDIAN),y)
|
|
override LD += -EL
|
|
LDEMULATION := lppc
|