b3f95490b9
This adds initial support for kernel 4.14 based on the patches for kernel 4.9. In the configuration I deactivated some of the new possible security features like: CONFIG_REFCOUNT_FULL CONFIG_SLAB_FREELIST_HARDENED CONFIG_SOFTLOCKUP_DETECTOR CONFIG_WARN_ALL_UNSEEDED_RANDOM And these overlay FS options are also deactivated: CONFIG_OVERLAY_FS_INDEX CONFIG_OVERLAY_FS_REDIRECT_DIR I activated this: CONFIG_FORTIFY_SOURCE CONFIG_POSIX_TIMERS CONFIG_SLAB_MERGE_DEFAULT CONFIG_WATCHDOG_HANDLE_BOOT_ENABLED I am not sure if I did the porting correct for the following patches: target/linux/generic/backport-4.14/020-backport_netfilter_rtcache.patch target/linux/generic/hack-4.14/220-gc_sections.patch target/linux/generic/hack-4.14/321-powerpc_crtsavres_prereq.patch target/linux/generic/pending-4.14/305-mips_module_reloc.patch target/linux/generic/pending-4.14/611-netfilter_match_bypass_default_table.patch target/linux/generic/pending-4.14/680-NET-skip-GRO-for-foreign-MAC-addresses.patch Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
71 lines
2.6 KiB
Diff
71 lines
2.6 KiB
Diff
From b3d00b452467f621317953d9e4c6f9ae8dcfd271 Mon Sep 17 00:00:00 2001
|
|
From: Imre Kaloz <kaloz@openwrt.org>
|
|
Date: Fri, 7 Jul 2017 17:06:55 +0200
|
|
Subject: use the openwrt lzma options for now
|
|
|
|
lede-commit: 548de949f392049420a6a1feeef118b30ab8ea8c
|
|
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|
---
|
|
lib/decompress.c | 1 +
|
|
scripts/Makefile.lib | 2 +-
|
|
scripts/gen_initramfs_list.sh | 10 +++++-----
|
|
3 files changed, 7 insertions(+), 6 deletions(-)
|
|
|
|
--- a/lib/decompress.c
|
|
+++ b/lib/decompress.c
|
|
@@ -49,6 +49,7 @@ static const struct compress_format comp
|
|
{ {0x1f, 0x9e}, "gzip", gunzip },
|
|
{ {0x42, 0x5a}, "bzip2", bunzip2 },
|
|
{ {0x5d, 0x00}, "lzma", unlzma },
|
|
+ { {0x6d, 0x00}, "lzma-openwrt", unlzma },
|
|
{ {0xfd, 0x37}, "xz", unxz },
|
|
{ {0x89, 0x4c}, "lzo", unlzo },
|
|
{ {0x02, 0x21}, "lz4", unlz4 },
|
|
--- a/scripts/Makefile.lib
|
|
+++ b/scripts/Makefile.lib
|
|
@@ -348,7 +348,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
|
|
|
|
quiet_cmd_lzma = LZMA $@
|
|
cmd_lzma = (cat $(filter-out FORCE,$^) | \
|
|
- lzma -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
|
+ lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
|
(rm -f $@ ; false)
|
|
|
|
quiet_cmd_lzo = LZO $@
|
|
--- a/scripts/gen_initramfs_list.sh
|
|
+++ b/scripts/gen_initramfs_list.sh
|
|
@@ -229,7 +229,7 @@ cpio_list=
|
|
output="/dev/stdout"
|
|
output_file=""
|
|
is_cpio_compressed=
|
|
-compr="gzip -n -9 -f"
|
|
+compr="gzip -n -9 -f -"
|
|
|
|
arg="$1"
|
|
case "$arg" in
|
|
@@ -245,13 +245,13 @@ case "$arg" in
|
|
output=${cpio_list}
|
|
echo "$output_file" | grep -q "\.gz$" \
|
|
&& [ -x "`which gzip 2> /dev/null`" ] \
|
|
- && compr="gzip -n -9 -f"
|
|
+ && compr="gzip -n -9 -f -"
|
|
echo "$output_file" | grep -q "\.bz2$" \
|
|
&& [ -x "`which bzip2 2> /dev/null`" ] \
|
|
- && compr="bzip2 -9 -f"
|
|
+ && compr="bzip2 -9 -f -"
|
|
echo "$output_file" | grep -q "\.lzma$" \
|
|
&& [ -x "`which lzma 2> /dev/null`" ] \
|
|
- && compr="lzma -9 -f"
|
|
+ && compr="lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so"
|
|
echo "$output_file" | grep -q "\.xz$" \
|
|
&& [ -x "`which xz 2> /dev/null`" ] \
|
|
&& compr="xz --check=crc32 --lzma2=dict=1MiB"
|
|
@@ -320,7 +320,7 @@ if [ ! -z ${output_file} ]; then
|
|
if [ "${is_cpio_compressed}" = "compressed" ]; then
|
|
cat ${cpio_tfile} > ${output_file}
|
|
else
|
|
- (cat ${cpio_tfile} | ${compr} - > ${output_file}) \
|
|
+ (cat ${cpio_tfile} | ${compr} > ${output_file}) \
|
|
|| (rm -f ${output_file} ; false)
|
|
fi
|
|
[ -z ${cpio_file} ] && rm ${cpio_tfile}
|