a8f63a0717
This updates mac80211 to backprots-4.14-rc2. This was compile and runtime tested with ath9k, ath10k and b43 with multiple stations and ieee80211w and in different scenarios by many other people. To create the backports-4.14-rc2-1.tar.xz use this repository: https://git.kernel.org/pub/scm/linux/kernel/git/backports/backports.git from tag v4.14-rc2-1 Then run this: ./gentree.py --git-revision v4.14-rc2 --clean <path to linux repo> ../backports-4.14-rc2-1 This also adapts the ath10k-ct and mt76 driver to the changed cfg80211 APIs and syncs the nl80211.h file in iw with the new version from backports-4.14-rc2. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
37 lines
1.4 KiB
Diff
37 lines
1.4 KiB
Diff
--- a/drivers/net/wireless/ath/ath10k/Kconfig
|
|
+++ b/drivers/net/wireless/ath/ath10k/Kconfig
|
|
@@ -65,6 +65,12 @@ config ATH10K_TRACING
|
|
---help---
|
|
Select this to ath10k use tracing infrastructure.
|
|
|
|
+config ATH10K_THERMAL
|
|
+ bool "Atheros ath10k thermal monitoring support"
|
|
+ depends on THERMAL
|
|
+ ---help---
|
|
+ Select this to ath10k use hwmon for thermal measurement.
|
|
+
|
|
config ATH10K_DFS_CERTIFIED
|
|
bool "Atheros DFS support for certified platforms"
|
|
depends on ATH10K && CFG80211_CERTIFICATION_ONUS
|
|
--- a/drivers/net/wireless/ath/ath10k/Makefile
|
|
+++ b/drivers/net/wireless/ath/ath10k/Makefile
|
|
@@ -17,7 +17,7 @@ ath10k_core-y += mac.o \
|
|
ath10k_core-$(CPTCFG_ATH10K_DEBUGFS) += spectral.o
|
|
ath10k_core-$(CPTCFG_NL80211_TESTMODE) += testmode.o
|
|
ath10k_core-$(CPTCFG_ATH10K_TRACING) += trace.o
|
|
-ath10k_core-$(CONFIG_THERMAL) += thermal.o
|
|
+ath10k_core-$(CPTCFG_ATH10K_THERMAL) += thermal.o
|
|
ath10k_core-$(CPTCFG_MAC80211_DEBUGFS) += debugfs_sta.o
|
|
ath10k_core-$(CONFIG_PM) += wow.o
|
|
|
|
--- a/drivers/net/wireless/ath/ath10k/thermal.h
|
|
+++ b/drivers/net/wireless/ath/ath10k/thermal.h
|
|
@@ -36,7 +36,7 @@ struct ath10k_thermal {
|
|
int temperature;
|
|
};
|
|
|
|
-#if IS_REACHABLE(CONFIG_THERMAL)
|
|
+#if IS_REACHABLE(CPTCFG_ATH10K_THERMAL)
|
|
int ath10k_thermal_register(struct ath10k *ar);
|
|
void ath10k_thermal_unregister(struct ath10k *ar);
|
|
void ath10k_thermal_event_temperature(struct ath10k *ar, int temperature);
|