openwrtv4/target/linux/mpc83xx/patches-2.6.36/005-kernel_Makefile.patch
Alexandros C. Couloumbis e8e1084654 linux/mpc83xx: add preliminary 2.6.36 kernel support
SVN-Revision: 23633
2010-10-25 17:59:14 +00:00

14 lines
361 B
Diff

--- a/arch/powerpc/kernel/Makefile
+++ b/arch/powerpc/kernel/Makefile
@@ -116,9 +116,11 @@ obj-$(CONFIG_FSL_EMB_PERF_EVENT_E500) +=
obj-$(CONFIG_8XX_MINIMAL_FPEMU) += softemu8xx.o
+ifneq ($(CONFIG_RB_IOMAP),y)
ifneq ($(CONFIG_PPC_INDIRECT_IO),y)
obj-y += iomap.o
endif
+endif
obj-$(CONFIG_PPC64) += $(obj64-y)
obj-$(CONFIG_PPC32) += $(obj32-y)