5508510e74
The following features are working and tested: * both Ethernet ports * MMC * LED The following features are not working: * Wifi (There is a crappy driver we could port) * SPI flash (I haven't looked into this) I haven't tried out the rest. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
196 lines
5.4 KiB
Diff
196 lines
5.4 KiB
Diff
From daf75255fb67bf44db178e4c95a803b7972ed670 Mon Sep 17 00:00:00 2001
|
|
From: Hauke Mehrtens <hauke@hauke-m.de>
|
|
Date: Tue, 26 Sep 2017 22:29:06 +0200
|
|
Subject: ARM: dts: sunxi: add support for Orange Pi R1 board
|
|
|
|
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/sun8i-h2-plus-orangepi-r1.dts | 171 ++++++++++++++++++++++++
|
|
2 files changed, 172 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/sun8i-h2-plus-orangepi-r1.dts
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -819,6 +819,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
|
|
sun8i-a33-sinlinx-sina33.dtb \
|
|
sun8i-a83t-allwinner-h8homlet-v2.dtb \
|
|
sun8i-a83t-cubietruck-plus.dtb \
|
|
+ sun8i-h2-plus-orangepi-r1.dtb \
|
|
sun8i-h3-bananapi-m2-plus.dtb \
|
|
sun8i-h3-nanopi-neo.dtb \
|
|
sun8i-h3-orangepi-2.dtb \
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/sun8i-h2-plus-orangepi-r1.dts
|
|
@@ -0,0 +1,171 @@
|
|
+/*
|
|
+ * Copyright (C) 2017 Hauke Mehrtens <hauke@hauke-m.de>
|
|
+ *
|
|
+ * Based on sun8i-h2-plus-orangepi-zero.dts, which is:
|
|
+ * Copyright (C) 2016 Icenowy Zheng <icenowy@aosc.xyz>
|
|
+ *
|
|
+ * Based on sun8i-h3-orangepi-one.dts, which is:
|
|
+ * Copyright (C) 2016 Hans de Goede <hdegoede@redhat.com>
|
|
+ *
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
+ * licensing only applies to this file, and not this project as a
|
|
+ * whole.
|
|
+ *
|
|
+ * a) This file is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
+ * License, or (at your option) any later version.
|
|
+ *
|
|
+ * This file is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * Or, alternatively,
|
|
+ *
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
+ * obtaining a copy of this software and associated documentation
|
|
+ * files (the "Software"), to deal in the Software without
|
|
+ * restriction, including without limitation the rights to use,
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
+ * Software is furnished to do so, subject to the following
|
|
+ * conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+#include "sun8i-h3.dtsi"
|
|
+#include "sunxi-common-regulators.dtsi"
|
|
+
|
|
+#include <dt-bindings/gpio/gpio.h>
|
|
+#include <dt-bindings/input/input.h>
|
|
+#include <dt-bindings/pinctrl/sun4i-a10.h>
|
|
+
|
|
+/ {
|
|
+ model = "Xunlong Orange Pi R1";
|
|
+ compatible = "xunlong,orangepi-r1", "allwinner,sun8i-h2-plus";
|
|
+
|
|
+ aliases {
|
|
+ serial0 = &uart0;
|
|
+ /* ethernet0 is the H3 emac, defined in sun8i-h3.dtsi */
|
|
+ ethernet0 = &emac;
|
|
+ ethernet1 = &xr819;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ stdout-path = "serial0:115200n8";
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ pwr_led {
|
|
+ label = "orangepi:green:pwr";
|
|
+ gpios = <&r_pio 0 10 GPIO_ACTIVE_HIGH>;
|
|
+ default-state = "on";
|
|
+ };
|
|
+
|
|
+ status_led {
|
|
+ label = "orangepi:red:status";
|
|
+ gpios = <&pio 0 17 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ reg_vcc_wifi: reg_vcc_wifi {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ regulator-name = "vcc-wifi";
|
|
+ enable-active-high;
|
|
+ gpio = <&pio 0 20 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ wifi_pwrseq: wifi_pwrseq {
|
|
+ compatible = "mmc-pwrseq-simple";
|
|
+ reset-gpios = <&r_pio 0 7 GPIO_ACTIVE_LOW>;
|
|
+ post-power-on-delay-ms = <200>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ehci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&emac {
|
|
+ phy-handle = <&int_mii_phy>;
|
|
+ phy-mode = "mii";
|
|
+ allwinner,leds-active-low;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mmc0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&mmc0_pins_a>;
|
|
+ vmmc-supply = <®_vcc3v3>;
|
|
+ bus-width = <4>;
|
|
+ cd-gpios = <&pio 5 6 GPIO_ACTIVE_HIGH>; /* PF6 */
|
|
+ cd-inverted;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mmc1 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&mmc1_pins_a>;
|
|
+ vmmc-supply = <®_vcc_wifi>;
|
|
+ mmc-pwrseq = <&wifi_pwrseq>;
|
|
+ bus-width = <4>;
|
|
+ non-removable;
|
|
+ status = "okay";
|
|
+
|
|
+ /*
|
|
+ * Explicitly define the sdio device, so that we can add an ethernet
|
|
+ * alias for it (which e.g. makes u-boot set a mac-address).
|
|
+ */
|
|
+ xr819: sdio_wifi@1 {
|
|
+ reg = <1>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&mmc1_pins_a {
|
|
+ bias-pull-up;
|
|
+};
|
|
+
|
|
+&ohci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart0_pins_a>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&uart1 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart1_pins>;
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&uart2 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart2_pins>;
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&usbphy {
|
|
+ /* USB VBUS is always on */
|
|
+ status = "okay";
|
|
+};
|