74d00a8c38
* properly format/comment all patches * merge debloat patches * merge Kconfig patches * merge swconfig patches * merge hotplug patches * drop 200-fix_localversion.patch - upstream * drop 222-arm_zimage_none.patch - unused * drop 252-mv_cesa_depends.patch - no longer required * drop 410-mtd-move-forward-declaration-of-struct-mtd_info.patch - unused * drop 661-fq_codel_keep_dropped_stats.patch - outdated * drop 702-phy_add_aneg_done_function.patch - upstream * drop 840-rtc7301.patch - unused * drop 841-rtc_pt7c4338.patch - upstream * drop 921-use_preinit_as_init.patch - unused * drop spio-gpio-old and gpio-mmc - unused Signed-off-by: John Crispin <john@phrozen.org>
21 lines
643 B
Diff
21 lines
643 B
Diff
Disable MIPS VDSO until the cache issues have been sorted out.
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
|
|
--- a/arch/mips/vdso/Makefile
|
|
+++ b/arch/mips/vdso/Makefile
|
|
@@ -28,11 +28,11 @@ aflags-vdso := $(ccflags-vdso) \
|
|
# the comments on that file.
|
|
#
|
|
ifndef CONFIG_CPU_MIPSR6
|
|
- ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
|
|
- $(warning MIPS VDSO requires binutils >= 2.25)
|
|
+# ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
|
|
+# $(warning MIPS VDSO requires binutils >= 2.25)
|
|
obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
|
|
ccflags-vdso += -DDISABLE_MIPS_VDSO
|
|
- endif
|
|
+# endif
|
|
endif
|
|
|
|
# VDSO linker flags.
|