33d9d6c375
Building for octeon fails with 'arch/mips/vdso/vdso-n32.so.dbg' already contains a '.MIPS.abiflags' section if the file already exists from a prior build. Use the same workaround as the one for vdso.so.dbg committed in9eb155353a
. Commit91f205acaf
extended the workaround to cover vdso-o32.so.dbg but missed the vdso-n32.so.dbg which is added now by this change. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
29 lines
1.1 KiB
Diff
29 lines
1.1 KiB
Diff
--- a/arch/mips/vdso/Makefile
|
|
+++ b/arch/mips/vdso/Makefile
|
|
@@ -75,7 +75,7 @@ $(obj-vdso): KBUILD_AFLAGS := $(aflags-v
|
|
|
|
$(obj)/vdso.lds: KBUILD_CPPFLAGS := $(native-abi)
|
|
|
|
-$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) FORCE
|
|
+$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) $(obj)/genvdso FORCE
|
|
$(call if_changed,vdsold)
|
|
|
|
$(obj)/vdso-image.c: $(obj)/vdso.so.dbg $(obj)/genvdso FORCE
|
|
@@ -109,7 +109,7 @@ $(obj)/vdso-o32.lds: KBUILD_CPPFLAGS :=
|
|
$(obj)/vdso-o32.lds: $(src)/vdso.lds.S FORCE
|
|
$(call if_changed_dep,cpp_lds_S)
|
|
|
|
-$(obj)/vdso-o32.so.dbg: $(obj)/vdso-o32.lds $(obj-vdso-o32) FORCE
|
|
+$(obj)/vdso-o32.so.dbg: $(obj)/vdso-o32.lds $(obj-vdso-o32) $(obj)/genvdso FORCE
|
|
$(call if_changed,vdsold)
|
|
|
|
$(obj)/vdso-o32-image.c: VDSO_NAME := o32
|
|
@@ -145,7 +145,7 @@ $(obj)/vdso-n32.lds: KBUILD_CPPFLAGS :=
|
|
$(obj)/vdso-n32.lds: $(src)/vdso.lds.S FORCE
|
|
$(call if_changed_dep,cpp_lds_S)
|
|
|
|
-$(obj)/vdso-n32.so.dbg: $(obj)/vdso-n32.lds $(obj-vdso-n32) FORCE
|
|
+$(obj)/vdso-n32.so.dbg: $(obj)/vdso-n32.lds $(obj-vdso-n32) $(obj)/genvdso FORCE
|
|
$(call if_changed,vdsold)
|
|
|
|
$(obj)/vdso-n32-image.c: VDSO_NAME := n32
|