openwrtv4/target/linux/generic/patches-2.6.38/970-ocf_kbuild_integration.patch
Imre Kaloz 1f5d24e562 refresh patches with -rc6
SVN-Revision: 25805
2011-03-01 11:24:08 +00:00

20 lines
480 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -866,3 +866,6 @@ config CRYPTO_USER_API_SKCIPHER
source "drivers/crypto/Kconfig"
endif # if CRYPTO
+
+source "crypto/ocf/Kconfig"
+
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -89,6 +89,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+obj-$(CONFIG_OCF_OCF) += ocf/
+
#
# generic algorithms and the async_tx api
#