openwrtv4/target/linux/generic-2.6/patches-2.6.22/400-ledtrig_morse.patch
Gabor Juhos 7d8b70a1ec refresh generic 2.6.22 patches
SVN-Revision: 11186
2008-05-18 20:24:13 +00:00

23 lines
876 B
Diff

Index: linux-2.6.22.19/drivers/leds/Kconfig
===================================================================
--- linux-2.6.22.19.orig/drivers/leds/Kconfig
+++ linux-2.6.22.19/drivers/leds/Kconfig
@@ -128,5 +128,9 @@ config LEDS_TRIGGER_HEARTBEAT
load average.
If unsure, say Y.
+config LEDS_TRIGGER_MORSE
+ tristate "LED Morse Trigger"
+ depends on LEDS_TRIGGERS
+
endmenu
Index: linux-2.6.22.19/drivers/leds/Makefile
===================================================================
--- linux-2.6.22.19.orig/drivers/leds/Makefile
+++ linux-2.6.22.19/drivers/leds/Makefile
@@ -21,3 +21,4 @@ obj-$(CONFIG_LEDS_COBALT) += leds-cobal
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
+obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o