7bbf4117c6
This add support for kernel 4.9 to the ar71xx target. It was compile tested with the generic, NAND and mikrotik subtarget. Multiple members of the community tested it on their boards and did not report any major problem so far. Especially the NAND part received some changes to adapt to the new kernel APIs. The serial driver hack used for the Arduino Yun was not ported because the kernel changed there a lot. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
21 lines
823 B
Diff
21 lines
823 B
Diff
--- a/drivers/mtd/nand/Kconfig
|
|
+++ b/drivers/mtd/nand/Kconfig
|
|
@@ -569,4 +569,8 @@ config MTD_NAND_MTK
|
|
Enables support for NAND controller on MTK SoCs.
|
|
This controller is found on mt27xx, mt81xx, mt65xx SoCs.
|
|
|
|
+config MTD_NAND_RB4XX
|
|
+ tristate "NAND flash driver for RouterBoard 4xx series"
|
|
+ depends on MTD_NAND && ATH79_MACH_RB4XX
|
|
+
|
|
endif # MTD_NAND
|
|
--- a/drivers/mtd/nand/Makefile
|
|
+++ b/drivers/mtd/nand/Makefile
|
|
@@ -33,6 +33,7 @@ obj-$(CONFIG_MTD_NAND_CM_X270) += cmx27
|
|
obj-$(CONFIG_MTD_NAND_PXA3xx) += pxa3xx_nand.o
|
|
obj-$(CONFIG_MTD_NAND_TMIO) += tmio_nand.o
|
|
obj-$(CONFIG_MTD_NAND_PLATFORM) += plat_nand.o
|
|
+obj-$(CONFIG_MTD_NAND_RB4XX) += rb4xx_nand.o
|
|
obj-$(CONFIG_MTD_NAND_PASEMI) += pasemi_nand.o
|
|
obj-$(CONFIG_MTD_NAND_ORION) += orion_nand.o
|
|
obj-$(CONFIG_MTD_NAND_FSL_ELBC) += fsl_elbc_nand.o
|