b3f95490b9
This adds initial support for kernel 4.14 based on the patches for kernel 4.9. In the configuration I deactivated some of the new possible security features like: CONFIG_REFCOUNT_FULL CONFIG_SLAB_FREELIST_HARDENED CONFIG_SOFTLOCKUP_DETECTOR CONFIG_WARN_ALL_UNSEEDED_RANDOM And these overlay FS options are also deactivated: CONFIG_OVERLAY_FS_INDEX CONFIG_OVERLAY_FS_REDIRECT_DIR I activated this: CONFIG_FORTIFY_SOURCE CONFIG_POSIX_TIMERS CONFIG_SLAB_MERGE_DEFAULT CONFIG_WATCHDOG_HANDLE_BOOT_ENABLED I am not sure if I did the porting correct for the following patches: target/linux/generic/backport-4.14/020-backport_netfilter_rtcache.patch target/linux/generic/hack-4.14/220-gc_sections.patch target/linux/generic/hack-4.14/321-powerpc_crtsavres_prereq.patch target/linux/generic/pending-4.14/305-mips_module_reloc.patch target/linux/generic/pending-4.14/611-netfilter_match_bypass_default_table.patch target/linux/generic/pending-4.14/680-NET-skip-GRO-for-foreign-MAC-addresses.patch Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
64 lines
1.8 KiB
Diff
64 lines
1.8 KiB
Diff
From e3692cb2fcd5ba1244512a0f43b8118f65f1c375 Mon Sep 17 00:00:00 2001
|
|
From: Felix Fietkau <nbd@nbd.name>
|
|
Date: Sat, 8 Jul 2017 08:20:43 +0200
|
|
Subject: debloat: dmabuf
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
drivers/base/Kconfig | 2 +-
|
|
drivers/dma-buf/Makefile | 10 +++++++---
|
|
drivers/dma-buf/dma-buf.c | 4 +++-
|
|
kernel/sched/core.c | 1 +
|
|
4 files changed, 12 insertions(+), 5 deletions(-)
|
|
|
|
--- a/drivers/base/Kconfig
|
|
+++ b/drivers/base/Kconfig
|
|
@@ -243,7 +243,7 @@ config SOC_BUS
|
|
source "drivers/base/regmap/Kconfig"
|
|
|
|
config DMA_SHARED_BUFFER
|
|
- bool
|
|
+ tristate
|
|
default n
|
|
select ANON_INODES
|
|
help
|
|
--- a/drivers/dma-buf/Makefile
|
|
+++ b/drivers/dma-buf/Makefile
|
|
@@ -1,3 +1,7 @@
|
|
-obj-y := dma-buf.o dma-fence.o dma-fence-array.o reservation.o seqno-fence.o
|
|
-obj-$(CONFIG_SYNC_FILE) += sync_file.o
|
|
-obj-$(CONFIG_SW_SYNC) += sw_sync.o sync_debug.o
|
|
+obj-$(CONFIG_DMA_SHARED_BUFFER) := dma-shared-buffer.o
|
|
+
|
|
+dma-buf-objs-y := dma-buf.o dma-fence.o dma-fence-array.o reservation.o seqno-fence.o
|
|
+dma-buf-objs-$(CONFIG_SYNC_FILE) += sync_file.o
|
|
+dma-buf-objs-$(CONFIG_SW_SYNC) += sw_sync.o sync_debug.o
|
|
+
|
|
+dma-shared-buffer-objs := $(dma-buf-objs-y)
|
|
--- a/drivers/dma-buf/dma-buf.c
|
|
+++ b/drivers/dma-buf/dma-buf.c
|
|
@@ -34,6 +34,7 @@
|
|
#include <linux/poll.h>
|
|
#include <linux/reservation.h>
|
|
#include <linux/mm.h>
|
|
+#include <linux/module.h>
|
|
|
|
#include <uapi/linux/dma-buf.h>
|
|
|
|
@@ -1205,4 +1206,5 @@ static void __exit dma_buf_deinit(void)
|
|
{
|
|
dma_buf_uninit_debugfs();
|
|
}
|
|
-__exitcall(dma_buf_deinit);
|
|
+module_exit(dma_buf_deinit);
|
|
+MODULE_LICENSE("GPL");
|
|
--- a/kernel/sched/core.c
|
|
+++ b/kernel/sched/core.c
|
|
@@ -2146,6 +2146,7 @@ int wake_up_state(struct task_struct *p,
|
|
{
|
|
return try_to_wake_up(p, state, 0);
|
|
}
|
|
+EXPORT_SYMBOL_GPL(wake_up_state);
|
|
|
|
/*
|
|
* Perform scheduler related setup for a newly forked process p.
|