74d00a8c38
* properly format/comment all patches * merge debloat patches * merge Kconfig patches * merge swconfig patches * merge hotplug patches * drop 200-fix_localversion.patch - upstream * drop 222-arm_zimage_none.patch - unused * drop 252-mv_cesa_depends.patch - no longer required * drop 410-mtd-move-forward-declaration-of-struct-mtd_info.patch - unused * drop 661-fq_codel_keep_dropped_stats.patch - outdated * drop 702-phy_add_aneg_done_function.patch - upstream * drop 840-rtc7301.patch - unused * drop 841-rtc_pt7c4338.patch - upstream * drop 921-use_preinit_as_init.patch - unused * drop spio-gpio-old and gpio-mmc - unused Signed-off-by: John Crispin <john@phrozen.org>
39 lines
1 KiB
Diff
39 lines
1 KiB
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -12,6 +12,16 @@ menuconfig PHYLIB
|
|
|
|
if PHYLIB
|
|
|
|
+config SWCONFIG
|
|
+ tristate "Switch configuration API"
|
|
+ ---help---
|
|
+ Switch configuration API using netlink. This allows
|
|
+ you to configure the VLAN features of certain switches.
|
|
+
|
|
+config SWCONFIG_LEDS
|
|
+ bool "Switch LED trigger support"
|
|
+ depends on (SWCONFIG && LEDS_TRIGGERS)
|
|
+
|
|
comment "MII PHY device drivers"
|
|
|
|
config AQUANTIA_PHY
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -3,6 +3,7 @@
|
|
libphy-objs := phy.o phy_device.o mdio_bus.o
|
|
|
|
obj-$(CONFIG_PHYLIB) += libphy.o
|
|
+obj-$(CONFIG_SWCONFIG) += swconfig.o
|
|
obj-$(CONFIG_AQUANTIA_PHY) += aquantia.o
|
|
obj-$(CONFIG_MARVELL_PHY) += marvell.o
|
|
obj-$(CONFIG_DAVICOM_PHY) += davicom.o
|
|
--- a/include/uapi/linux/Kbuild
|
|
+++ b/include/uapi/linux/Kbuild
|
|
@@ -388,6 +388,7 @@ header-y += stddef.h
|
|
header-y += string.h
|
|
header-y += suspend_ioctls.h
|
|
header-y += swab.h
|
|
+header-y += switch.h
|
|
header-y += synclink.h
|
|
header-y += sysctl.h
|
|
header-y += sysinfo.h
|