cd9c2492c1
This patch ports the cybertan_part code from ar71xx and converts the driver to a DT-supported mtd parser. As a result, it will no longer add the u-boot, nvram and art partitions, which were never part of the special Cybertan header. Instead these partitions have to be specified in the DT, which has the upside of making it possible to add properties (i.e.: read-only), labels and references to these important partitions. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
19 lines
872 B
Diff
19 lines
872 B
Diff
--- a/drivers/mtd/parsers/Makefile 2018-08-12 02:32:47.951243067 +0200
|
|
+++ b/drivers/mtd/parsers/Makefile 2018-08-12 02:33:09.844626814 +0200
|
|
@@ -1 +1,2 @@
|
|
+obj-$(CONFIG_MTD_PARSER_CYBERTAN) += parser_cybertan.o
|
|
obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
|
|
--- a/drivers/mtd/parsers/Kconfig 2018-08-12 02:28:43.987357803 +0200
|
|
+++ b/drivers/mtd/parsers/Kconfig 2018-08-12 02:32:23.237852972 +0200
|
|
@@ -1,3 +1,11 @@
|
|
+config MTD_PARSER_CYBERTAN
|
|
+ tristate "Parser for Cybertan format partitions"
|
|
+ depends on MTD && (ATH79 || COMPILE_TEST)
|
|
+ help
|
|
+ Cybertan has a proprietory header than encompasses a Broadcom trx
|
|
+ header. This driver will parse the header and take care of the
|
|
+ special offsets that result in the extra headers.
|
|
+
|
|
config MTD_PARSER_TRX
|
|
tristate "Parser for TRX format partitions"
|
|
depends on MTD && (BCM47XX || ARCH_BCM_5301X || COMPILE_TEST)
|