openwrtv4/target/linux/generic/patches-3.14/302-mips_no_branch_likely.patch
Felix Fietkau fe295cd178 kernel: when using --gc-sections, add --sort-section=name to get a more stable sorting order
Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 41951
2014-08-02 18:50:55 +00:00

11 lines
523 B
Diff

--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -87,7 +87,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
# machines may also. Since BFD is incredibly buggy with respect to
# crossformat linking we rely on the elf2ecoff tool for format conversion.
#
-cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
+cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
cflags-y += -msoft-float
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib --gc-sections --sort-section=name
KBUILD_AFLAGS_MODULE += -mlong-calls