759f111f8d
A new test case was adding in one of the patches fixing a problem, this
also included a change in the test/Makefile.am to add this test case.
The build system detected a change in the Makefile.am and wants to
regenerate the Makefile.in, but this fails because automake-1.15 is not
installed yet. As automake depends on patch being build first, make sure
we do not modify the Makefile.am.
This fixes build problem seen by the build bots.
Fixes: 4797dddfde
("patch: apply upstream cve fixes")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
25 lines
770 B
Diff
25 lines
770 B
Diff
From daa51e492049d9fe3ac049165ec19641bf19cd7f Mon Sep 17 00:00:00 2001
|
|
From: Andreas Gruenbacher <agruen@gnu.org>
|
|
Date: Fri, 17 Aug 2018 13:35:40 +0200
|
|
Subject: [PATCH] Fix swapping fake lines in pch_swap
|
|
|
|
* src/pch.c (pch_swap): Fix swapping p_bfake and p_efake when there is a
|
|
blank line in the middle of a context-diff hunk: that empty line stays
|
|
in the middle of the hunk and isn't swapped.
|
|
|
|
Fixes: https://savannah.gnu.org/bugs/index.php?53133
|
|
---
|
|
src/pch.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/src/pch.c
|
|
+++ b/src/pch.c
|
|
@@ -2114,7 +2114,7 @@ pch_swap (void)
|
|
}
|
|
if (p_efake >= 0) { /* fix non-freeable ptr range */
|
|
if (p_efake <= i)
|
|
- n = p_end - i + 1;
|
|
+ n = p_end - p_ptrn_lines;
|
|
else
|
|
n = -i;
|
|
p_efake += n;
|