74d00a8c38
* properly format/comment all patches * merge debloat patches * merge Kconfig patches * merge swconfig patches * merge hotplug patches * drop 200-fix_localversion.patch - upstream * drop 222-arm_zimage_none.patch - unused * drop 252-mv_cesa_depends.patch - no longer required * drop 410-mtd-move-forward-declaration-of-struct-mtd_info.patch - unused * drop 661-fq_codel_keep_dropped_stats.patch - outdated * drop 702-phy_add_aneg_done_function.patch - upstream * drop 840-rtc7301.patch - unused * drop 841-rtc_pt7c4338.patch - upstream * drop 921-use_preinit_as_init.patch - unused * drop spio-gpio-old and gpio-mmc - unused Signed-off-by: John Crispin <john@phrozen.org>
52 lines
1.8 KiB
Diff
52 lines
1.8 KiB
Diff
From: Gabor Juhos <juhosg@openwrt.org>
|
|
Subject: usr: sanitize deps_initramfs list
|
|
|
|
If any filename in the intramfs dependency
|
|
list contains a colon, that causes a kernel
|
|
build error like this:
|
|
|
|
/devel/openwrt/build_dir/linux-ar71xx_generic/linux-3.6.6/usr/Makefile:58: *** multiple target patterns. Stop.
|
|
make[5]: *** [usr] Error 2
|
|
|
|
Fix it by removing such filenames from the
|
|
deps_initramfs list.
|
|
|
|
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|
---
|
|
usr/Makefile | 8 +++++---
|
|
1 file changed, 5 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/usr/Makefile b/usr/Makefile
|
|
index e767f019accf..17328d3c11cc 100644
|
|
--- a/usr/Makefile
|
|
+++ b/usr/Makefile
|
|
@@ -53,6 +53,8 @@ ifneq ($(wildcard $(obj)/.initramfs_data.cpio.d),)
|
|
include $(obj)/.initramfs_data.cpio.d
|
|
endif
|
|
|
|
+deps_initramfs_sane := $(foreach v,$(deps_initramfs),$(if $(findstring :,$(v)),,$(v)))
|
|
+
|
|
quiet_cmd_initfs = GEN $@
|
|
cmd_initfs = $(initramfs) -o $@ $(ramfs-args) $(ramfs-input)
|
|
|
|
@@ -61,14 +63,14 @@ targets := initramfs_data.cpio.gz initramfs_data.cpio.bz2 \
|
|
initramfs_data.cpio.lzo initramfs_data.cpio.lz4 \
|
|
initramfs_data.cpio
|
|
# do not try to update files included in initramfs
|
|
-$(deps_initramfs): ;
|
|
+$(deps_initramfs_sane): ;
|
|
|
|
-$(deps_initramfs): klibcdirs
|
|
+$(deps_initramfs_sane): klibcdirs
|
|
# We rebuild initramfs_data.cpio if:
|
|
# 1) Any included file is newer then initramfs_data.cpio
|
|
# 2) There are changes in which files are included (added or deleted)
|
|
# 3) If gen_init_cpio are newer than initramfs_data.cpio
|
|
# 4) arguments to gen_initramfs.sh changes
|
|
-$(obj)/initramfs_data.cpio$(suffix_y): $(obj)/gen_init_cpio $(deps_initramfs) klibcdirs
|
|
+$(obj)/initramfs_data.cpio$(suffix_y): $(obj)/gen_init_cpio $(deps_initramfs_sane) klibcdirs
|
|
$(Q)$(initramfs) -l $(ramfs-input) > $(obj)/.initramfs_data.cpio.d
|
|
$(call if_changed,initfs)
|
|
--
|
|
2.11.0
|
|
|