openwrtv4/target/linux/generic/patches-2.6.39/403-ledtrig-usbdev.patch
Felix Fietkau 127e4ebd32 generic: Add support for 2.6.39
Add support for 2.6.39 based on rc3. Runtime tested on bcm63xx.

SVN-Revision: 26615
2011-04-12 19:39:20 +00:00

21 lines
761 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -460,4 +460,11 @@ config LEDS_TRIGGER_NETDEV
This allows LEDs to be controlled by network device activity.
If unsure, say Y.
+config LEDS_TRIGGER_USBDEV
+ tristate "LED USB device Trigger"
+ depends on USB && LEDS_TRIGGERS
+ help
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -55,3 +55,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o