b13e981d72
This activates support for fit images and some other new mkimage features. Some of the patches were applied upstream and could be removed. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
14 lines
408 B
Diff
14 lines
408 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -634,7 +634,10 @@ UBOOTINCLUDE := \
|
|
-I$(srctree)/arch/$(ARCH)/include \
|
|
-include $(srctree)/include/linux/kconfig.h
|
|
|
|
-NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
+ifneq ($(shell uname),FreeBSD)
|
|
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
+endif
|
|
+
|
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
|
|
# FIX ME
|