31116661ff
update to the version of the driver that is on its way upstream Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 47898
29 lines
898 B
Diff
29 lines
898 B
Diff
From 86ab021705a493a5276261953f4f2cb071df6722 Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <blogic@openwrt.org>
|
|
Date: Mon, 22 Apr 2013 23:20:03 +0200
|
|
Subject: [PATCH 35/53] NET: MIPS: add ralink SoC ethernet driver
|
|
|
|
Add support for Ralink FE and ESW.
|
|
|
|
Signed-off-by: John Crispin <blogic@openwrt.org>
|
|
---
|
|
arch/mips/ralink/rt305x.c | 1 +
|
|
drivers/net/ethernet/Kconfig | 1 +
|
|
drivers/net/ethernet/Makefile | 1 +
|
|
3 files changed, 3 insertions(+)
|
|
|
|
diff --git a/arch/mips/ralink/rt305x.c b/arch/mips/ralink/rt305x.c
|
|
index 51f33a5..d7c4ba4 100644
|
|
--- a/arch/mips/ralink/rt305x.c
|
|
+++ b/arch/mips/ralink/rt305x.c
|
|
@@ -199,6 +199,7 @@ void __init ralink_clk_init(void)
|
|
}
|
|
|
|
ralink_clk_add("cpu", cpu_rate);
|
|
+ ralink_clk_add("sys", sys_rate);
|
|
ralink_clk_add("10000b00.spi", sys_rate);
|
|
ralink_clk_add("10000b40.spi", sys_rate);
|
|
ralink_clk_add("10000100.timer", wdt_rate);
|
|
--
|
|
1.7.10.4
|
|
|