6aebc6b16b
fixes: CVE-2016-3739: TLS certificate check bypass with mbedTLS/PolarSSL - remove crypto auth compile fix curl changelog of 7.46 states its fixed - fix mbedtls and cyassl usability #19621 : add path to certificate file (from Mozilla via curl) and provide this in a new package tested on ar71xx w. curl/mbedtls/wolfssl Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
22 lines
695 B
Diff
22 lines
695 B
Diff
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -150,7 +150,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
|
bin_SCRIPTS = curl-config
|
|
|
|
SUBDIRS = lib src include
|
|
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs scripts
|
|
+DIST_SUBDIRS = $(SUBDIRS) packages
|
|
|
|
pkgconfigdir = $(libdir)/pkgconfig
|
|
pkgconfig_DATA = libcurl.pc
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -611,7 +611,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
|
|
|
bin_SCRIPTS = curl-config
|
|
SUBDIRS = lib src include
|
|
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs scripts
|
|
+DIST_SUBDIRS = $(SUBDIRS) packages
|
|
pkgconfigdir = $(libdir)/pkgconfig
|
|
pkgconfig_DATA = libcurl.pc
|
|
LIB_VAUTH_CFILES = vauth/vauth.c vauth/cleartext.c vauth/cram.c \
|