3256194aff
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 44922
30 lines
953 B
Diff
30 lines
953 B
Diff
Index: linux-4.0-rc4/drivers/ata/Kconfig
|
|
===================================================================
|
|
--- linux-4.0-rc4.orig/drivers/ata/Kconfig
|
|
+++ linux-4.0-rc4/drivers/ata/Kconfig
|
|
@@ -401,6 +401,13 @@ config SATA_VITESSE
|
|
|
|
If unsure, say N.
|
|
|
|
+config SATA_OXNAS
|
|
+ tristate "PLXTECH NAS782X SATA support"
|
|
+ help
|
|
+ This option enables support for Nas782x Serial ATA controller.
|
|
+
|
|
+ If unsure, say N.
|
|
+
|
|
comment "PATA SFF controllers with BMDMA"
|
|
|
|
config PATA_ALI
|
|
Index: linux-4.0-rc4/drivers/ata/Makefile
|
|
===================================================================
|
|
--- linux-4.0-rc4.orig/drivers/ata/Makefile
|
|
+++ linux-4.0-rc4/drivers/ata/Makefile
|
|
@@ -37,6 +37,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
|
|
obj-$(CONFIG_SATA_ULI) += sata_uli.o
|
|
obj-$(CONFIG_SATA_VIA) += sata_via.o
|
|
obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
|
|
+obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
|
|
|
|
# SFF PATA w/ BMDMA
|
|
obj-$(CONFIG_PATA_ALI) += pata_ali.o
|