3a2e735b96
This fixes GIC interrupts (required before switching to 4.9), adds few new entires & introduces DTS for Archer C5. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
130 lines
2.9 KiB
Diff
130 lines
2.9 KiB
Diff
From d6661da842bbeec2082b7263c9e682792e7951a9 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
|
|
Date: Tue, 14 Mar 2017 11:39:41 +0100
|
|
Subject: [PATCH] ARM: dts: BCM5301X: Add support for TP-LINK Archer C5 V2
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
This is BCM47081A0 based home router with BCM43217 and BCM4352 wireless
|
|
chipsets.
|
|
|
|
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
|
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/bcm47081-tplink-archer-c5-v2.dts | 98 ++++++++++++++++++++++
|
|
2 files changed, 99 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/bcm47081-tplink-archer-c5-v2.dts
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -86,6 +86,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
|
bcm47081-buffalo-wzr-900dhp.dtb \
|
|
bcm47081-luxul-xap-1410.dtb \
|
|
bcm47081-luxul-xwr-1200.dtb \
|
|
+ bcm47081-tplink-archer-c5-v2.dtb \
|
|
bcm4709-asus-rt-ac87u.dtb \
|
|
bcm4709-buffalo-wxr-1900dhp.dtb \
|
|
bcm4709-linksys-ea9200.dtb \
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm47081-tplink-archer-c5-v2.dts
|
|
@@ -0,0 +1,98 @@
|
|
+/*
|
|
+ * Copyright (C) 2017 Rafał Miłecki <rafal@milecki.pl>
|
|
+ *
|
|
+ * Licensed under the ISC license.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "bcm47081.dtsi"
|
|
+
|
|
+/ {
|
|
+ compatible = "tplink,archer-c5-v2", "brcm,bcm47081", "brcm,bcm4708";
|
|
+ model = "TP-LINK Archer C5 V2";
|
|
+
|
|
+ chosen {
|
|
+ bootargs = "earlycon";
|
|
+ };
|
|
+
|
|
+ memory {
|
|
+ reg = <0x00000000 0x08000000>;
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ 2ghz {
|
|
+ label = "bcm53xx:green:2ghz";
|
|
+ gpios = <&chipcommon 0 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ lan {
|
|
+ label = "bcm53xx:green:lan";
|
|
+ gpios = <&chipcommon 1 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ usb2-port1 {
|
|
+ label = "bcm53xx:green:usb2-port1";
|
|
+ gpios = <&chipcommon 2 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ power {
|
|
+ label = "bcm53xx:green:power";
|
|
+ gpios = <&chipcommon 4 GPIO_ACTIVE_HIGH>;
|
|
+ linux,default-trigger = "default-on";
|
|
+ };
|
|
+
|
|
+ wan-green {
|
|
+ label = "bcm53xx:green:wan";
|
|
+ gpios = <&chipcommon 5 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ wps {
|
|
+ label = "bcm53xx:green:wps";
|
|
+ gpios = <&chipcommon 6 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ wan-amber {
|
|
+ label = "bcm53xx:amber:wan";
|
|
+ gpios = <&chipcommon 8 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ 5ghz {
|
|
+ label = "bcm53xx:green:5ghz";
|
|
+ gpios = <&chipcommon 12 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ usb2-port2 {
|
|
+ label = "bcm53xx:green:usb2-port2";
|
|
+ gpios = <&chipcommon 13 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ gpio-keys {
|
|
+ compatible = "gpio-keys";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ rfkill {
|
|
+ label = "WiFi";
|
|
+ linux,code = <KEY_RFKILL>;
|
|
+ gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+
|
|
+ restart {
|
|
+ label = "Reset";
|
|
+ linux,code = <KEY_RESTART>;
|
|
+ gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&spi_nor {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usb2 {
|
|
+ vcc-gpio = <&chipcommon 9 GPIO_ACTIVE_HIGH>;
|
|
+};
|