f791fb4af4
Signed-off-by: Felix Fietkau <nbd@nbd.name> Signed-off-by: Tim Harvey <tharvey@gateworks.com> [fixes]
18 lines
594 B
Diff
18 lines
594 B
Diff
Disable MIPS VDSO until the cache issues have been sorted out.
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
|
|
--- a/arch/mips/vdso/Makefile
|
|
+++ b/arch/mips/vdso/Makefile
|
|
@@ -28,9 +28,9 @@ aflags-vdso := $(ccflags-vdso) \
|
|
ifndef CONFIG_CPU_MIPSR6
|
|
ifeq ($(call ld-ifversion, -lt, 225000000, y),y)
|
|
$(warning MIPS VDSO requires binutils >= 2.25)
|
|
- obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
|
|
- ccflags-vdso += -DDISABLE_MIPS_VDSO
|
|
endif
|
|
+ obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
|
|
+ ccflags-vdso += -DDISABLE_MIPS_VDSO
|
|
endif
|
|
|
|
# VDSO linker flags.
|