046618f5da
Refresh patches. Compile-tested on ramips/mt7621 and x86/64. Runtime-tested on ramips/mt7621 and x86/64. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
101 lines
3.3 KiB
Diff
101 lines
3.3 KiB
Diff
From b14784e7883390c20ed3ff904892255404a5914b Mon Sep 17 00:00:00 2001
|
|
From: Felix Fietkau <nbd@nbd.name>
|
|
Date: Fri, 7 Jul 2017 17:05:53 +0200
|
|
Subject: add an optional config option for stripping all unnecessary symbol exports from the kernel image
|
|
|
|
lede-commit: bb5a40c64b7c4f4848509fa0a6625055fc9e66cc
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
include/asm-generic/vmlinux.lds.h | 18 +++++++++++++++---
|
|
include/linux/export.h | 9 ++++++++-
|
|
scripts/Makefile.build | 2 +-
|
|
3 files changed, 24 insertions(+), 5 deletions(-)
|
|
|
|
--- a/include/asm-generic/vmlinux.lds.h
|
|
+++ b/include/asm-generic/vmlinux.lds.h
|
|
@@ -54,6 +54,16 @@
|
|
#define LOAD_OFFSET 0
|
|
#endif
|
|
|
|
+#ifndef SYMTAB_KEEP
|
|
+#define SYMTAB_KEEP KEEP(*(SORT(___ksymtab+*)))
|
|
+#define SYMTAB_KEEP_GPL KEEP(*(SORT(___ksymtab_gpl+*)))
|
|
+#endif
|
|
+
|
|
+#ifndef SYMTAB_DISCARD
|
|
+#define SYMTAB_DISCARD
|
|
+#define SYMTAB_DISCARD_GPL
|
|
+#endif
|
|
+
|
|
#include <linux/export.h>
|
|
|
|
/* Align . to a 8 byte boundary equals to maximum function alignment. */
|
|
@@ -342,14 +352,14 @@
|
|
/* Kernel symbol table: Normal symbols */ \
|
|
__ksymtab : AT(ADDR(__ksymtab) - LOAD_OFFSET) { \
|
|
VMLINUX_SYMBOL(__start___ksymtab) = .; \
|
|
- KEEP(*(SORT(___ksymtab+*))) \
|
|
+ SYMTAB_KEEP \
|
|
VMLINUX_SYMBOL(__stop___ksymtab) = .; \
|
|
} \
|
|
\
|
|
/* Kernel symbol table: GPL-only symbols */ \
|
|
__ksymtab_gpl : AT(ADDR(__ksymtab_gpl) - LOAD_OFFSET) { \
|
|
VMLINUX_SYMBOL(__start___ksymtab_gpl) = .; \
|
|
- KEEP(*(SORT(___ksymtab_gpl+*))) \
|
|
+ SYMTAB_KEEP_GPL \
|
|
VMLINUX_SYMBOL(__stop___ksymtab_gpl) = .; \
|
|
} \
|
|
\
|
|
@@ -411,7 +421,7 @@
|
|
\
|
|
/* Kernel symbol table: strings */ \
|
|
__ksymtab_strings : AT(ADDR(__ksymtab_strings) - LOAD_OFFSET) { \
|
|
- *(__ksymtab_strings) \
|
|
+ *(__ksymtab_strings+*) \
|
|
} \
|
|
\
|
|
/* __*init sections */ \
|
|
@@ -763,6 +773,8 @@
|
|
EXIT_TEXT \
|
|
EXIT_DATA \
|
|
EXIT_CALL \
|
|
+ SYMTAB_DISCARD \
|
|
+ SYMTAB_DISCARD_GPL \
|
|
*(.discard) \
|
|
*(.discard.*) \
|
|
}
|
|
--- a/include/linux/export.h
|
|
+++ b/include/linux/export.h
|
|
@@ -53,12 +53,19 @@ extern struct module __this_module;
|
|
#define __CRC_SYMBOL(sym, sec)
|
|
#endif
|
|
|
|
+#ifdef MODULE
|
|
+#define __EXPORT_SUFFIX(sym)
|
|
+#else
|
|
+#define __EXPORT_SUFFIX(sym) "+" #sym
|
|
+#endif
|
|
+
|
|
/* For every exported symbol, place a struct in the __ksymtab section */
|
|
#define ___EXPORT_SYMBOL(sym, sec) \
|
|
extern typeof(sym) sym; \
|
|
__CRC_SYMBOL(sym, sec) \
|
|
static const char __kstrtab_##sym[] \
|
|
- __attribute__((section("__ksymtab_strings"), aligned(1))) \
|
|
+ __attribute__((section("__ksymtab_strings" \
|
|
+ __EXPORT_SUFFIX(sym)), aligned(1))) \
|
|
= VMLINUX_SYMBOL_STR(sym); \
|
|
static const struct kernel_symbol __ksymtab_##sym \
|
|
__used \
|
|
--- a/scripts/Makefile.build
|
|
+++ b/scripts/Makefile.build
|
|
@@ -398,7 +398,7 @@ targets += $(extra-y) $(MAKECMDGOALS) $(
|
|
# Linker scripts preprocessor (.lds.S -> .lds)
|
|
# ---------------------------------------------------------------------------
|
|
quiet_cmd_cpp_lds_S = LDS $@
|
|
- cmd_cpp_lds_S = $(CPP) $(cpp_flags) -P -C -U$(ARCH) \
|
|
+ cmd_cpp_lds_S = $(CPP) $(EXTRA_LDSFLAGS) $(cpp_flags) -P -C -U$(ARCH) \
|
|
-D__ASSEMBLY__ -DLINKER_SCRIPT -o $@ $<
|
|
|
|
$(obj)/%.lds: $(src)/%.lds.S FORCE
|