2d02a4f5bd
Refresh patches. Adapt 704-phy-no-genphy-soft-reset.patch. Remove brcm2708/950-0005-mm-Remove-the-PFN-busy-warning.patch. Compile-tested on brcm2708/bcm2708 and x86/64. Runtime-tested on brcm2708/bcm2708 and x86/64. Fixes the following vulnerabilities: - CVE-2017-7533 - CVE-2017-1000111 - CVE-2017-1000112 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
44 lines
1.6 KiB
Diff
44 lines
1.6 KiB
Diff
From c9ef4ab0f54356ee9f91d9676ea0ec123840ddc7 Mon Sep 17 00:00:00 2001
|
|
From: Felix Fietkau <nbd@nbd.name>
|
|
Date: Fri, 7 Jul 2017 16:57:33 +0200
|
|
Subject: kernel: do not build modules.order
|
|
|
|
It is not needed for anything on the system and skipping this saves some
|
|
build time, especially in cases where there is nothing to do.
|
|
|
|
lede-commit: afc1675833a7bf5df094f59f7250369520646d04
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
Makefile | 2 --
|
|
scripts/Makefile.build | 2 +-
|
|
2 files changed, 1 insertion(+), 3 deletions(-)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1196,7 +1196,6 @@ all: modules
|
|
|
|
PHONY += modules
|
|
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
|
|
- $(Q)$(AWK) '!x[$$0]++' $(vmlinux-dirs:%=$(objtree)/%/modules.order) > $(objtree)/modules.order
|
|
@$(kecho) ' Building modules, stage 2.';
|
|
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
|
|
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
|
|
@@ -1226,7 +1225,6 @@ _modinst_:
|
|
rm -f $(MODLIB)/build ; \
|
|
ln -s $(CURDIR) $(MODLIB)/build ; \
|
|
fi
|
|
- @cp -f $(objtree)/modules.order $(MODLIB)/
|
|
@cp -f $(objtree)/modules.builtin $(MODLIB)/
|
|
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modinst
|
|
|
|
--- a/scripts/Makefile.build
|
|
+++ b/scripts/Makefile.build
|
|
@@ -93,7 +93,7 @@ modorder-target := $(obj)/modules.order
|
|
# We keep a list of all modules in $(MODVERDIR)
|
|
|
|
__build: $(if $(KBUILD_BUILTIN),$(builtin-target) $(lib-target) $(extra-y)) \
|
|
- $(if $(KBUILD_MODULES),$(obj-m) $(modorder-target)) \
|
|
+ $(if $(KBUILD_MODULES),$(obj-m)) \
|
|
$(subdir-ym) $(always)
|
|
@:
|
|
|