7bbf4117c6
This add support for kernel 4.9 to the ar71xx target. It was compile tested with the generic, NAND and mikrotik subtarget. Multiple members of the community tested it on their boards and did not report any major problem so far. Especially the NAND part received some changes to adapt to the new kernel APIs. The serial driver hack used for the Arduino Yun was not ported because the kernel changed there a lot. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
24 lines
755 B
Diff
24 lines
755 B
Diff
--- a/drivers/net/dsa/Kconfig
|
|
+++ b/drivers/net/dsa/Kconfig
|
|
@@ -9,6 +9,13 @@ config NET_DSA_MV88E6060
|
|
This enables support for the Marvell 88E6060 ethernet switch
|
|
chip.
|
|
|
|
+config NET_DSA_MV88E6063
|
|
+ bool "Marvell 88E6063 ethernet switch chip support"
|
|
+ select NET_DSA_TAG_TRAILER
|
|
+ ---help---
|
|
+ This enables support for the Marvell 88E6063 ethernet switch
|
|
+ chip
|
|
+
|
|
config NET_DSA_BCM_SF2
|
|
tristate "Broadcom Starfighter 2 Ethernet switch support"
|
|
depends on HAS_IOMEM && NET_DSA
|
|
--- a/drivers/net/dsa/Makefile
|
|
+++ b/drivers/net/dsa/Makefile
|
|
@@ -1,4 +1,5 @@
|
|
obj-$(CONFIG_NET_DSA_MV88E6060) += mv88e6060.o
|
|
+obj-$(CONFIG_NET_DSA_MV88E6063) += mv88e6063.o
|
|
obj-$(CONFIG_NET_DSA_BCM_SF2) += bcm_sf2.o
|
|
obj-$(CONFIG_NET_DSA_QCA8K) += qca8k.o
|
|
|