4e07167eff
This fixes the following security problems: CVE-2016-8615: cookie injection for other servers CVE-2016-8616: case insensitive password comparison CVE-2016-8617: OOB write via unchecked multiplication CVE-2016-8618: double-free in curl_maprintf CVE-2016-8619: double-free in krb5 code CVE-2016-8620: glob parser write/read out of bounds CVE-2016-8621: curl_getdate read out of bounds CVE-2016-8622: URL unescape heap overflow via integer truncation CVE-2016-8623: Use-after-free via shared cookies CVE-2016-8624: invalid URL parsing with '#' CVE-2016-8625: IDNA 2003 makes curl use wrong host Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
22 lines
695 B
Diff
22 lines
695 B
Diff
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -153,7 +153,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
|
bin_SCRIPTS = curl-config
|
|
|
|
SUBDIRS = lib src include
|
|
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs scripts
|
|
+DIST_SUBDIRS = $(SUBDIRS) packages
|
|
|
|
pkgconfigdir = $(libdir)/pkgconfig
|
|
pkgconfig_DATA = libcurl.pc
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -613,7 +613,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
|
|
|
bin_SCRIPTS = curl-config
|
|
SUBDIRS = lib src include
|
|
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs scripts
|
|
+DIST_SUBDIRS = $(SUBDIRS) packages
|
|
pkgconfigdir = $(libdir)/pkgconfig
|
|
pkgconfig_DATA = libcurl.pc
|
|
LIB_VAUTH_CFILES = vauth/vauth.c vauth/cleartext.c vauth/cram.c \
|