74d00a8c38
* properly format/comment all patches * merge debloat patches * merge Kconfig patches * merge swconfig patches * merge hotplug patches * drop 200-fix_localversion.patch - upstream * drop 222-arm_zimage_none.patch - unused * drop 252-mv_cesa_depends.patch - no longer required * drop 410-mtd-move-forward-declaration-of-struct-mtd_info.patch - unused * drop 661-fq_codel_keep_dropped_stats.patch - outdated * drop 702-phy_add_aneg_done_function.patch - upstream * drop 840-rtc7301.patch - unused * drop 841-rtc_pt7c4338.patch - upstream * drop 921-use_preinit_as_init.patch - unused * drop spio-gpio-old and gpio-mmc - unused Signed-off-by: John Crispin <john@phrozen.org>
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
Upstream doesn't optimize the kernel and bootwrappers for ppc44x because
|
|
they still want to support gcc 3.3 -- well, we don't.
|
|
|
|
--- a/arch/powerpc/Makefile
|
|
+++ b/arch/powerpc/Makefile
|
|
@@ -205,7 +205,8 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
|
|
KBUILD_CFLAGS += -mno-sched-epilog
|
|
endif
|
|
|
|
-cpu-as-$(CONFIG_4xx) += -Wa,-m405
|
|
+cpu-as-$(CONFIG_40x) += -Wa,-m405
|
|
+cpu-as-$(CONFIG_44x) += -Wa,-m440
|
|
cpu-as-$(CONFIG_ALTIVEC) += -Wa,-maltivec
|
|
cpu-as-$(CONFIG_E200) += -Wa,-me200
|
|
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -48,10 +48,10 @@ BOOTCFLAGS += -I$(obj) -I$(srctree)/$(ob
|
|
DTC_FLAGS ?= -p 1024
|
|
|
|
$(obj)/4xx.o: BOOTCFLAGS += -mcpu=405
|
|
-$(obj)/ebony.o: BOOTCFLAGS += -mcpu=405
|
|
+$(obj)/ebony.o: BOOTCFLAGS += -mcpu=440
|
|
$(obj)/cuboot-hotfoot.o: BOOTCFLAGS += -mcpu=405
|
|
-$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=405
|
|
-$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=405
|
|
+$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=440
|
|
+$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=440
|
|
$(obj)/cuboot-acadia.o: BOOTCFLAGS += -mcpu=405
|
|
$(obj)/treeboot-walnut.o: BOOTCFLAGS += -mcpu=405
|
|
$(obj)/treeboot-iss4xx.o: BOOTCFLAGS += -mcpu=405
|