cac1a4be66
several people reported this bug to be causing drop out issues Signed-off-by: John Crispin <john@phrozen.org>
617 lines
19 KiB
Diff
617 lines
19 KiB
Diff
From: Sebastian Gottschall <s.gottschall@newmedia-net.de>
|
|
|
|
Adds LED and GPIO Control support for 988x, 9887, 9888, 99x0, 9984 based
|
|
chipsets with on chipset connected led's using WMI Firmware API. The LED
|
|
device will get available named as "ath10k-phyX" at sysfs and can be controlled
|
|
with various triggers. adds also debugfs interface for gpio control.
|
|
|
|
This patch is specific for OpenWRt base, as is use old backported package
|
|
with old wireless source. Support for QCA9984 is removed and a simbol
|
|
is added to local-simbol file to export the actually compile the code
|
|
with the ATH10K_LEDS simbol.
|
|
|
|
|
|
Signed-off-by: Sebastian Gottschall <s.gottschall@dd-wrt.com>
|
|
Reviewed-by: Steve deRosier <derosier@cal-sierra.com>
|
|
[kvalo: major reorg and cleanup]
|
|
Signed-off-by: Kalle Valo <kvalo@codeaurora.org>
|
|
Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
|
|
---
|
|
|
|
v13:
|
|
|
|
* only compile tested!
|
|
|
|
* fix all checkpatch warnings
|
|
|
|
* fix commit log
|
|
|
|
* sizeof(struct ath10k_gpiocontrol) -> sizeof(*gpio)
|
|
|
|
* unsigned -> unsigned int
|
|
|
|
* remove GPIOLIB code, that should be added in a separate patch
|
|
|
|
* rename gpio.c to leds.c
|
|
|
|
* add leds.h
|
|
|
|
* rename some functions:
|
|
|
|
ath10k_attach_led() -> ath10k_leds_register()
|
|
ath10k_unregister_led() -> ath10k_leds_unregister()
|
|
ath10k_reset_led_pin() -> ath10k_leds_start()
|
|
|
|
* call ath10k_leds_unregister() before ath10k_thermal_unregister() to preserve ordering
|
|
|
|
* call ath10k_leds_start() only from ath10k_core_start() and not from mac.c
|
|
|
|
* rename struct ath10k_gpiocontrol as anonymous function under struct
|
|
ath10k::leds, no need for memory allocation
|
|
|
|
* merge ath10k_add_led() to ath10k_attach_led(), which is it's only caller
|
|
|
|
* remove #if IS_ENABLED() checks from most of places, memory savings from those were not worth it
|
|
|
|
* Kconfig help text improvement and move it lower in the menu, also don't enable it by default
|
|
|
|
* switch to set_brightness_blocking() so that the callback can sleep,
|
|
then no need to use ath10k_wmi_cmd_send_nowait() and can take mutex
|
|
to access ar->state
|
|
|
|
* don't touch ath10k_wmi_pdev_get_temperature()
|
|
|
|
* as QCA6174/QCA9377 are not (yet) supported don't add the command to WMI-TLV interface
|
|
|
|
* remove debugfs interface, that should be added in another patch
|
|
|
|
* cleanup includes
|
|
|
|
|
|
drivers/net/wireless/ath/ath10k/Kconfig | 10 +++
|
|
drivers/net/wireless/ath/ath10k/Makefile | 1 +
|
|
drivers/net/wireless/ath/ath10k/core.c | 22 +++++++
|
|
drivers/net/wireless/ath/ath10k/core.h | 9 ++-
|
|
drivers/net/wireless/ath/ath10k/hw.h | 1 +
|
|
drivers/net/wireless/ath/ath10k/leds.c | 103 ++++++++++++++++++++++++++++++
|
|
drivers/net/wireless/ath/ath10k/leds.h | 45 +++++++++++++
|
|
drivers/net/wireless/ath/ath10k/mac.c | 1 +
|
|
drivers/net/wireless/ath/ath10k/wmi-ops.h | 32 ++++++++++
|
|
drivers/net/wireless/ath/ath10k/wmi-tlv.c | 2 +
|
|
drivers/net/wireless/ath/ath10k/wmi.c | 54 ++++++++++++++++
|
|
drivers/net/wireless/ath/ath10k/wmi.h | 35 ++++++++++
|
|
12 files changed, 314 insertions(+), 1 deletion(-)
|
|
create mode 100644 drivers/net/wireless/ath/ath10k/leds.c
|
|
create mode 100644 drivers/net/wireless/ath/ath10k/leds.h
|
|
--- a/drivers/net/wireless/ath/ath10k/Kconfig
|
|
+++ b/drivers/net/wireless/ath/ath10k/Kconfig
|
|
@@ -56,6 +56,16 @@ config ATH10K_DEBUGFS
|
|
|
|
If unsure, say Y to make it easier to debug problems.
|
|
|
|
+config ATH10K_LEDS
|
|
+ bool "Atheros ath10k LED support"
|
|
+ depends on ATH10K
|
|
+ select MAC80211_LEDS
|
|
+ select LEDS_CLASS
|
|
+ select NEW_LEDS
|
|
+ default y
|
|
+ ---help---
|
|
+ This option is necessary, if you want LED support for chipset connected led pins. If unsure, say N.
|
|
+
|
|
config ATH10K_SPECTRAL
|
|
bool "Atheros ath10k spectral scan support"
|
|
depends on ATH10K_DEBUGFS
|
|
--- a/drivers/net/wireless/ath/ath10k/Makefile
|
|
+++ b/drivers/net/wireless/ath/ath10k/Makefile
|
|
@@ -18,6 +18,7 @@ ath10k_core-$(CPTCFG_ATH10K_SPECTRAL) +=
|
|
ath10k_core-$(CPTCFG_NL80211_TESTMODE) += testmode.o
|
|
ath10k_core-$(CPTCFG_ATH10K_TRACING) += trace.o
|
|
ath10k_core-$(CPTCFG_ATH10K_THERMAL) += thermal.o
|
|
+ath10k_core-$(CPTCFG_ATH10K_LEDS) += leds.o
|
|
ath10k_core-$(CPTCFG_MAC80211_DEBUGFS) += debugfs_sta.o
|
|
ath10k_core-$(CONFIG_PM) += wow.o
|
|
|
|
--- a/local-symbols
|
|
+++ b/local-symbols
|
|
@@ -144,6 +144,7 @@ ATH10K_DEBUG=
|
|
ATH10K_DEBUGFS=
|
|
ATH10K_SPECTRAL=
|
|
ATH10K_THERMAL=
|
|
+ATH10K_LEDS=
|
|
ATH10K_TRACING=
|
|
ATH10K_DFS_CERTIFIED=
|
|
WCN36XX=
|
|
--- a/drivers/net/wireless/ath/ath10k/core.c
|
|
+++ b/drivers/net/wireless/ath/ath10k/core.c
|
|
@@ -32,6 +32,7 @@
|
|
#include "htt.h"
|
|
#include "testmode.h"
|
|
#include "wmi-ops.h"
|
|
+#include "leds.h"
|
|
|
|
unsigned int ath10k_debug_mask;
|
|
static unsigned int ath10k_cryptmode_param;
|
|
@@ -56,6 +57,7 @@ static const struct ath10k_hw_params ath
|
|
.id = QCA988X_HW_2_0_VERSION,
|
|
.dev_id = QCA988X_2_0_DEVICE_ID,
|
|
.name = "qca988x hw2.0",
|
|
+ .led_pin = 1,
|
|
.patch_load_addr = QCA988X_HW_2_0_PATCH_LOAD_ADDR,
|
|
.uart_pin = 7,
|
|
.cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_ALL,
|
|
@@ -80,6 +82,7 @@ static const struct ath10k_hw_params ath
|
|
.id = QCA9887_HW_1_0_VERSION,
|
|
.dev_id = QCA9887_1_0_DEVICE_ID,
|
|
.name = "qca9887 hw1.0",
|
|
+ .led_pin = 1,
|
|
.patch_load_addr = QCA9887_HW_1_0_PATCH_LOAD_ADDR,
|
|
.uart_pin = 7,
|
|
.cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_ALL,
|
|
@@ -199,6 +202,7 @@ static const struct ath10k_hw_params ath
|
|
.id = QCA99X0_HW_2_0_DEV_VERSION,
|
|
.dev_id = QCA99X0_2_0_DEVICE_ID,
|
|
.name = "qca99x0 hw2.0",
|
|
+ .led_pin = 17,
|
|
.patch_load_addr = QCA99X0_HW_2_0_PATCH_LOAD_ADDR,
|
|
.uart_pin = 7,
|
|
.otp_exe_param = 0x00000700,
|
|
@@ -228,6 +232,7 @@ static const struct ath10k_hw_params ath
|
|
.id = QCA9984_HW_1_0_DEV_VERSION,
|
|
.dev_id = QCA9984_1_0_DEVICE_ID,
|
|
.name = "qca9984/qca9994 hw1.0",
|
|
+ .led_pin = 17,
|
|
.patch_load_addr = QCA9984_HW_1_0_PATCH_LOAD_ADDR,
|
|
.uart_pin = 7,
|
|
.cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
|
|
@@ -262,6 +267,7 @@ static const struct ath10k_hw_params ath
|
|
.id = QCA9888_HW_2_0_DEV_VERSION,
|
|
.dev_id = QCA9888_2_0_DEVICE_ID,
|
|
.name = "qca9888 hw2.0",
|
|
+ .led_pin = 17,
|
|
.patch_load_addr = QCA9888_HW_2_0_PATCH_LOAD_ADDR,
|
|
.uart_pin = 7,
|
|
.cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
|
|
@@ -2254,6 +2260,10 @@ int ath10k_core_start(struct ath10k *ar,
|
|
if (status)
|
|
goto err_hif_stop;
|
|
|
|
+ status = ath10k_leds_start(ar);
|
|
+ if (status)
|
|
+ goto err_hif_stop;
|
|
+
|
|
return 0;
|
|
|
|
err_hif_stop:
|
|
@@ -2471,9 +2481,18 @@ static void ath10k_core_register_work(st
|
|
goto err_spectral_destroy;
|
|
}
|
|
|
|
+ status = ath10k_leds_register(ar);
|
|
+ if (status) {
|
|
+ ath10k_err(ar, "could not register leds: %d\n",
|
|
+ status);
|
|
+ goto err_thermal_unregister;
|
|
+ }
|
|
+
|
|
set_bit(ATH10K_FLAG_CORE_REGISTERED, &ar->dev_flags);
|
|
return;
|
|
|
|
+err_thermal_unregister:
|
|
+ ath10k_thermal_unregister(ar);
|
|
err_spectral_destroy:
|
|
ath10k_spectral_destroy(ar);
|
|
err_debug_destroy:
|
|
@@ -2515,6 +2534,8 @@ void ath10k_core_unregister(struct ath10
|
|
if (!test_bit(ATH10K_FLAG_CORE_REGISTERED, &ar->dev_flags))
|
|
return;
|
|
|
|
+ ath10k_leds_unregister(ar);
|
|
+
|
|
ath10k_thermal_unregister(ar);
|
|
/* Stop spectral before unregistering from mac80211 to remove the
|
|
* relayfs debugfs file cleanly. Otherwise the parent debugfs tree
|
|
--- a/drivers/net/wireless/ath/ath10k/core.h
|
|
+++ b/drivers/net/wireless/ath/ath10k/core.h
|
|
@@ -24,6 +24,7 @@
|
|
#include <linux/pci.h>
|
|
#include <linux/uuid.h>
|
|
#include <linux/time.h>
|
|
+#include <linux/leds.h>
|
|
|
|
#include "htt.h"
|
|
#include "htc.h"
|
|
@@ -789,7 +790,6 @@ struct ath10k {
|
|
u32 low_5ghz_chan;
|
|
u32 high_5ghz_chan;
|
|
bool ani_enabled;
|
|
-
|
|
bool p2p;
|
|
|
|
struct {
|
|
@@ -972,6 +972,13 @@ struct ath10k {
|
|
} testmode;
|
|
|
|
struct {
|
|
+ struct gpio_led wifi_led;
|
|
+ struct led_classdev cdev;
|
|
+ char label[48];
|
|
+ u32 gpio_state_pin;
|
|
+ } leds;
|
|
+
|
|
+ struct {
|
|
/* protected by data_lock */
|
|
u32 fw_crash_counter;
|
|
u32 fw_warm_reset_counter;
|
|
--- a/drivers/net/wireless/ath/ath10k/hw.h
|
|
+++ b/drivers/net/wireless/ath/ath10k/hw.h
|
|
@@ -490,6 +490,7 @@ struct ath10k_hw_params {
|
|
const char *name;
|
|
u32 patch_load_addr;
|
|
int uart_pin;
|
|
+ int led_pin;
|
|
u32 otp_exe_param;
|
|
|
|
/* Type of hw cycle counter wraparound logic, for more info
|
|
--- /dev/null
|
|
+++ b/drivers/net/wireless/ath/ath10k/leds.c
|
|
@@ -0,0 +1,103 @@
|
|
+/*
|
|
+ * Copyright (c) 2005-2011 Atheros Communications Inc.
|
|
+ * Copyright (c) 2011-2017 Qualcomm Atheros, Inc.
|
|
+ * Copyright (c) 2018 Sebastian Gottschall <s.gottschall@dd-wrt.com>
|
|
+ * Copyright (c) 2018, The Linux Foundation. All rights reserved.
|
|
+ *
|
|
+ * Permission to use, copy, modify, and/or distribute this software for any
|
|
+ * purpose with or without fee is hereby granted, provided that the above
|
|
+ * copyright notice and this permission notice appear in all copies.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
|
|
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
|
|
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
|
|
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
|
|
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
|
|
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
|
|
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
|
+ */
|
|
+
|
|
+#include <linux/leds.h>
|
|
+
|
|
+#include "core.h"
|
|
+#include "wmi.h"
|
|
+#include "wmi-ops.h"
|
|
+
|
|
+#include "leds.h"
|
|
+
|
|
+static int ath10k_leds_set_brightness_blocking(struct led_classdev *led_cdev,
|
|
+ enum led_brightness brightness)
|
|
+{
|
|
+ struct ath10k *ar = container_of(led_cdev, struct ath10k,
|
|
+ leds.cdev);
|
|
+ struct gpio_led *led = &ar->leds.wifi_led;
|
|
+
|
|
+ mutex_lock(&ar->conf_mutex);
|
|
+
|
|
+ if (ar->state != ATH10K_STATE_ON)
|
|
+ goto out;
|
|
+
|
|
+ ar->leds.gpio_state_pin = (brightness != LED_OFF) ^ led->active_low;
|
|
+ ath10k_wmi_gpio_output(ar, led->gpio, ar->leds.gpio_state_pin);
|
|
+
|
|
+out:
|
|
+ mutex_unlock(&ar->conf_mutex);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+int ath10k_leds_start(struct ath10k *ar)
|
|
+{
|
|
+ if (ar->hw_params.led_pin == 0)
|
|
+ /* leds not supported */
|
|
+ return 0;
|
|
+
|
|
+ /* under some circumstances, the gpio pin gets reconfigured
|
|
+ * to default state by the firmware, so we need to
|
|
+ * reconfigure it this behaviour has only ben seen on
|
|
+ * QCA9984 and QCA99XX devices so far
|
|
+ */
|
|
+ ath10k_wmi_gpio_config(ar, ar->hw_params.led_pin, 0,
|
|
+ WMI_GPIO_PULL_NONE, WMI_GPIO_INTTYPE_DISABLE);
|
|
+ ath10k_wmi_gpio_output(ar, ar->hw_params.led_pin, 1);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+int ath10k_leds_register(struct ath10k *ar)
|
|
+{
|
|
+ int ret;
|
|
+
|
|
+ if (ar->hw_params.led_pin == 0)
|
|
+ /* leds not supported */
|
|
+ return 0;
|
|
+
|
|
+ snprintf(ar->leds.label, sizeof(ar->leds.label), "ath10k-%s",
|
|
+ wiphy_name(ar->hw->wiphy));
|
|
+ ar->leds.wifi_led.active_low = 1;
|
|
+ ar->leds.wifi_led.gpio = ar->hw_params.led_pin;
|
|
+ ar->leds.wifi_led.name = ar->leds.label;
|
|
+ ar->leds.wifi_led.default_state = LEDS_GPIO_DEFSTATE_KEEP;
|
|
+
|
|
+ ar->leds.cdev.name = ar->leds.label;
|
|
+ ar->leds.cdev.brightness_set_blocking = ath10k_leds_set_brightness_blocking;
|
|
+
|
|
+ /* FIXME: this assignment doesn't make sense as it's NULL, remove it? */
|
|
+ ar->leds.cdev.default_trigger = ar->leds.wifi_led.default_trigger;
|
|
+
|
|
+ ret = led_classdev_register(wiphy_dev(ar->hw->wiphy), &ar->leds.cdev);
|
|
+ if (ret)
|
|
+ return ret;
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+void ath10k_leds_unregister(struct ath10k *ar)
|
|
+{
|
|
+ if (ar->hw_params.led_pin == 0)
|
|
+ /* leds not supported */
|
|
+ return;
|
|
+
|
|
+ led_classdev_unregister(&ar->leds.cdev);
|
|
+}
|
|
+
|
|
--- /dev/null
|
|
+++ b/drivers/net/wireless/ath/ath10k/leds.h
|
|
@@ -0,0 +1,41 @@
|
|
+/*
|
|
+ * Copyright (c) 2018, The Linux Foundation. All rights reserved.
|
|
+ *
|
|
+ * Permission to use, copy, modify, and/or distribute this software for any
|
|
+ * purpose with or without fee is hereby granted, provided that the above
|
|
+ * copyright notice and this permission notice appear in all copies.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
|
|
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
|
|
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
|
|
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
|
|
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
|
|
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
|
|
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
|
+ */
|
|
+#ifndef _LEDS_H_
|
|
+#define _LEDS_H_
|
|
+
|
|
+#include "core.h"
|
|
+
|
|
+#ifdef CPTCFG_ATH10K_LEDS
|
|
+void ath10k_leds_unregister(struct ath10k *ar);
|
|
+int ath10k_leds_start(struct ath10k *ar);
|
|
+int ath10k_leds_register(struct ath10k *ar);
|
|
+#else
|
|
+static inline void ath10k_leds_unregister(struct ath10k *ar)
|
|
+{
|
|
+}
|
|
+
|
|
+static inline int ath10k_leds_start(struct ath10k *ar)
|
|
+{
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static inline int ath10k_leds_register(struct ath10k *ar)
|
|
+{
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+#endif
|
|
+#endif /* _LEDS_H_ */
|
|
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
|
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
|
@@ -32,6 +32,7 @@
|
|
#include "wmi-tlv.h"
|
|
#include "wmi-ops.h"
|
|
#include "wow.h"
|
|
+#include "leds.h"
|
|
|
|
/*********/
|
|
/* Rates */
|
|
--- a/drivers/net/wireless/ath/ath10k/wmi-ops.h
|
|
+++ b/drivers/net/wireless/ath/ath10k/wmi-ops.h
|
|
@@ -197,6 +197,10 @@ struct wmi_ops {
|
|
(struct ath10k *ar,
|
|
enum wmi_bss_survey_req_type type);
|
|
struct sk_buff *(*gen_echo)(struct ath10k *ar, u32 value);
|
|
+ struct sk_buff *(*gen_gpio_config)(struct ath10k *ar, u32 gpio_num,
|
|
+ u32 input, u32 pull_type, u32 intr_mode);
|
|
+
|
|
+ struct sk_buff *(*gen_gpio_output)(struct ath10k *ar, u32 gpio_num, u32 set);
|
|
};
|
|
|
|
int ath10k_wmi_cmd_send(struct ath10k *ar, struct sk_buff *skb, u32 cmd_id);
|
|
@@ -951,6 +955,35 @@ ath10k_wmi_force_fw_hang(struct ath10k *
|
|
return ath10k_wmi_cmd_send(ar, skb, ar->wmi.cmd->force_fw_hang_cmdid);
|
|
}
|
|
|
|
+static inline int ath10k_wmi_gpio_config(struct ath10k *ar, u32 gpio_num,
|
|
+ u32 input, u32 pull_type, u32 intr_mode)
|
|
+{
|
|
+ struct sk_buff *skb;
|
|
+
|
|
+ if (!ar->wmi.ops->gen_gpio_config)
|
|
+ return -EOPNOTSUPP;
|
|
+
|
|
+ skb = ar->wmi.ops->gen_gpio_config(ar, gpio_num, input, pull_type, intr_mode);
|
|
+ if (IS_ERR(skb))
|
|
+ return PTR_ERR(skb);
|
|
+
|
|
+ return ath10k_wmi_cmd_send(ar, skb, ar->wmi.cmd->gpio_config_cmdid);
|
|
+}
|
|
+
|
|
+static inline int ath10k_wmi_gpio_output(struct ath10k *ar, u32 gpio_num, u32 set)
|
|
+{
|
|
+ struct sk_buff *skb;
|
|
+
|
|
+ if (!ar->wmi.ops->gen_gpio_config)
|
|
+ return -EOPNOTSUPP;
|
|
+
|
|
+ skb = ar->wmi.ops->gen_gpio_output(ar, gpio_num, set);
|
|
+ if (IS_ERR(skb))
|
|
+ return PTR_ERR(skb);
|
|
+
|
|
+ return ath10k_wmi_cmd_send(ar, skb, ar->wmi.cmd->gpio_output_cmdid);
|
|
+}
|
|
+
|
|
static inline int
|
|
ath10k_wmi_dbglog_cfg(struct ath10k *ar, u64 module_enable, u32 log_level)
|
|
{
|
|
--- a/drivers/net/wireless/ath/ath10k/wmi-tlv.c
|
|
+++ b/drivers/net/wireless/ath/ath10k/wmi-tlv.c
|
|
@@ -3619,6 +3619,8 @@ static const struct wmi_ops wmi_tlv_ops
|
|
.gen_echo = ath10k_wmi_tlv_op_gen_echo,
|
|
.gen_vdev_spectral_conf = ath10k_wmi_tlv_op_gen_vdev_spectral_conf,
|
|
.gen_vdev_spectral_enable = ath10k_wmi_tlv_op_gen_vdev_spectral_enable,
|
|
+ /* .gen_gpio_config not implemented */
|
|
+ /* .gen_gpio_output not implemented */
|
|
};
|
|
|
|
static const struct wmi_peer_flags_map wmi_tlv_peer_flags_map = {
|
|
--- a/drivers/net/wireless/ath/ath10k/wmi.c
|
|
+++ b/drivers/net/wireless/ath/ath10k/wmi.c
|
|
@@ -6580,6 +6580,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
|
|
return skb;
|
|
}
|
|
|
|
+static struct sk_buff *ath10k_wmi_op_gen_gpio_config(struct ath10k *ar,
|
|
+ u32 gpio_num, u32 input,
|
|
+ u32 pull_type, u32 intr_mode)
|
|
+{
|
|
+ struct wmi_gpio_config_cmd *cmd;
|
|
+ struct sk_buff *skb;
|
|
+
|
|
+ skb = ath10k_wmi_alloc_skb(ar, sizeof(*cmd));
|
|
+ if (!skb)
|
|
+ return ERR_PTR(-ENOMEM);
|
|
+
|
|
+ cmd = (struct wmi_gpio_config_cmd *)skb->data;
|
|
+ cmd->pull_type = __cpu_to_le32(pull_type);
|
|
+ cmd->gpio_num = __cpu_to_le32(gpio_num);
|
|
+ cmd->input = __cpu_to_le32(input);
|
|
+ cmd->intr_mode = __cpu_to_le32(intr_mode);
|
|
+
|
|
+ ath10k_dbg(ar, ATH10K_DBG_WMI, "wmi gpio_config gpio_num 0x%08x input 0x%08x pull_type 0x%08x intr_mode 0x%08x\n",
|
|
+ gpio_num, input, pull_type, intr_mode);
|
|
+
|
|
+ return skb;
|
|
+}
|
|
+
|
|
+static struct sk_buff *ath10k_wmi_op_gen_gpio_output(struct ath10k *ar,
|
|
+ u32 gpio_num, u32 set)
|
|
+{
|
|
+ struct wmi_gpio_output_cmd *cmd;
|
|
+ struct sk_buff *skb;
|
|
+
|
|
+ skb = ath10k_wmi_alloc_skb(ar, sizeof(*cmd));
|
|
+ if (!skb)
|
|
+ return ERR_PTR(-ENOMEM);
|
|
+
|
|
+ cmd = (struct wmi_gpio_output_cmd *)skb->data;
|
|
+ cmd->gpio_num = __cpu_to_le32(gpio_num);
|
|
+ cmd->set = __cpu_to_le32(set);
|
|
+
|
|
+ ath10k_dbg(ar, ATH10K_DBG_WMI, "wmi gpio_output gpio_num 0x%08x set 0x%08x\n",
|
|
+ gpio_num, set);
|
|
+
|
|
+ return skb;
|
|
+}
|
|
+
|
|
static struct sk_buff *
|
|
ath10k_wmi_op_gen_set_psmode(struct ath10k *ar, u32 vdev_id,
|
|
enum wmi_sta_ps_mode psmode)
|
|
@@ -8081,6 +8124,9 @@ static const struct wmi_ops wmi_ops = {
|
|
.fw_stats_fill = ath10k_wmi_main_op_fw_stats_fill,
|
|
.get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
|
|
.gen_echo = ath10k_wmi_op_gen_echo,
|
|
+ .gen_gpio_config = ath10k_wmi_op_gen_gpio_config,
|
|
+ .gen_gpio_output = ath10k_wmi_op_gen_gpio_output,
|
|
+
|
|
/* .gen_bcn_tmpl not implemented */
|
|
/* .gen_prb_tmpl not implemented */
|
|
/* .gen_p2p_go_bcn_ie not implemented */
|
|
@@ -8151,6 +8197,8 @@ static const struct wmi_ops wmi_10_1_ops
|
|
.fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
|
|
.get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
|
|
.gen_echo = ath10k_wmi_op_gen_echo,
|
|
+ .gen_gpio_config = ath10k_wmi_op_gen_gpio_config,
|
|
+ .gen_gpio_output = ath10k_wmi_op_gen_gpio_output,
|
|
/* .gen_bcn_tmpl not implemented */
|
|
/* .gen_prb_tmpl not implemented */
|
|
/* .gen_p2p_go_bcn_ie not implemented */
|
|
@@ -8222,6 +8270,8 @@ static const struct wmi_ops wmi_10_2_ops
|
|
.gen_delba_send = ath10k_wmi_op_gen_delba_send,
|
|
.fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
|
|
.get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
|
|
+ .gen_gpio_config = ath10k_wmi_op_gen_gpio_config,
|
|
+ .gen_gpio_output = ath10k_wmi_op_gen_gpio_output,
|
|
/* .gen_pdev_enable_adaptive_cca not implemented */
|
|
};
|
|
|
|
@@ -8292,6 +8342,8 @@ static const struct wmi_ops wmi_10_2_4_o
|
|
.gen_pdev_enable_adaptive_cca =
|
|
ath10k_wmi_op_gen_pdev_enable_adaptive_cca,
|
|
.get_vdev_subtype = ath10k_wmi_10_2_4_op_get_vdev_subtype,
|
|
+ .gen_gpio_config = ath10k_wmi_op_gen_gpio_config,
|
|
+ .gen_gpio_output = ath10k_wmi_op_gen_gpio_output,
|
|
/* .gen_bcn_tmpl not implemented */
|
|
/* .gen_prb_tmpl not implemented */
|
|
/* .gen_p2p_go_bcn_ie not implemented */
|
|
@@ -8367,6 +8419,8 @@ static const struct wmi_ops wmi_10_4_ops
|
|
.gen_pdev_bss_chan_info_req = ath10k_wmi_10_2_op_gen_pdev_bss_chan_info,
|
|
.gen_echo = ath10k_wmi_op_gen_echo,
|
|
.gen_pdev_get_tpc_config = ath10k_wmi_10_2_4_op_gen_pdev_get_tpc_config,
|
|
+ .gen_gpio_config = ath10k_wmi_op_gen_gpio_config,
|
|
+ .gen_gpio_output = ath10k_wmi_op_gen_gpio_output,
|
|
};
|
|
|
|
int ath10k_wmi_attach(struct ath10k *ar)
|
|
--- a/drivers/net/wireless/ath/ath10k/wmi.h
|
|
+++ b/drivers/net/wireless/ath/ath10k/wmi.h
|
|
@@ -2899,6 +2899,41 @@ enum wmi_10_4_feature_mask {
|
|
|
|
};
|
|
|
|
+/* WMI_GPIO_CONFIG_CMDID */
|
|
+enum {
|
|
+ WMI_GPIO_PULL_NONE,
|
|
+ WMI_GPIO_PULL_UP,
|
|
+ WMI_GPIO_PULL_DOWN,
|
|
+};
|
|
+
|
|
+enum {
|
|
+ WMI_GPIO_INTTYPE_DISABLE,
|
|
+ WMI_GPIO_INTTYPE_RISING_EDGE,
|
|
+ WMI_GPIO_INTTYPE_FALLING_EDGE,
|
|
+ WMI_GPIO_INTTYPE_BOTH_EDGE,
|
|
+ WMI_GPIO_INTTYPE_LEVEL_LOW,
|
|
+ WMI_GPIO_INTTYPE_LEVEL_HIGH
|
|
+};
|
|
+
|
|
+/* WMI_GPIO_CONFIG_CMDID */
|
|
+struct wmi_gpio_config_cmd {
|
|
+ __le32 gpio_num; /* GPIO number to be setup */
|
|
+ __le32 input; /* 0 - Output/ 1 - Input */
|
|
+ __le32 pull_type; /* Pull type defined above */
|
|
+ __le32 intr_mode; /* Interrupt mode defined above (Input) */
|
|
+} __packed;
|
|
+
|
|
+/* WMI_GPIO_OUTPUT_CMDID */
|
|
+struct wmi_gpio_output_cmd {
|
|
+ __le32 gpio_num; /* GPIO number to be setup */
|
|
+ __le32 set; /* Set the GPIO pin*/
|
|
+} __packed;
|
|
+
|
|
+/* WMI_GPIO_INPUT_EVENTID */
|
|
+struct wmi_gpio_input_event {
|
|
+ __le32 gpio_num; /* GPIO number which changed state */
|
|
+} __packed;
|
|
+
|
|
struct wmi_ext_resource_config_10_4_cmd {
|
|
/* contains enum wmi_host_platform_type */
|
|
__le32 host_platform_config;
|