1f068588ef
Signed-off-by: Muciri Gatimu <muciri@openmesh.com> Signed-off-by: Shashidhar Lakkavalli <shashidhar.lakkavalli@openmesh.com> Signed-off-by: John Crispin <john@phrozen.org>
81 lines
2.8 KiB
Diff
81 lines
2.8 KiB
Diff
From 4ad0accdfb0941de1440906461c08bee715378d5 Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <john@phrozen.org>
|
|
Date: Thu, 10 Aug 2017 15:57:44 +0200
|
|
Subject: [PATCH 23/57] rng: add mediatek hw rng
|
|
|
|
Signed-off-by: John Crispin <john@phrozen.org>
|
|
---
|
|
drivers/char/hw_random/Kconfig | 14 ++++++++++++++
|
|
drivers/char/hw_random/Makefile | 1 +
|
|
drivers/crypto/Kconfig | 18 ++++++++++++++++++
|
|
drivers/crypto/Makefile | 1 +
|
|
4 files changed, 34 insertions(+)
|
|
|
|
--- a/drivers/char/hw_random/Kconfig
|
|
+++ b/drivers/char/hw_random/Kconfig
|
|
@@ -166,6 +166,20 @@ config HW_RANDOM_IXP4XX
|
|
|
|
If unsure, say Y.
|
|
|
|
+config HW_RANDOM_MTK
|
|
+ tristate "Mediatek Random Number Generator support"
|
|
+ depends on HW_RANDOM
|
|
+ depends on ARCH_MEDIATEK || COMPILE_TEST
|
|
+ default y
|
|
+ ---help---
|
|
+ This driver provides kernel-side support for the Random Number
|
|
+ Generator hardware found on Mediatek SoCs.
|
|
+
|
|
+ To compile this driver as a module, choose M here. the
|
|
+ module will be called mtk-rng.
|
|
+
|
|
+ If unsure, say Y.
|
|
+
|
|
config HW_RANDOM_OMAP
|
|
tristate "OMAP Random Number Generator support"
|
|
depends on ARCH_OMAP16XX || ARCH_OMAP2PLUS
|
|
--- a/drivers/char/hw_random/Makefile
|
|
+++ b/drivers/char/hw_random/Makefile
|
|
@@ -35,4 +35,5 @@ obj-$(CONFIG_HW_RANDOM_XGENE) += xgene-r
|
|
obj-$(CONFIG_HW_RANDOM_STM32) += stm32-rng.o
|
|
obj-$(CONFIG_HW_RANDOM_PIC32) += pic32-rng.o
|
|
obj-$(CONFIG_HW_RANDOM_MESON) += meson-rng.o
|
|
+obj-$(CONFIG_HW_RANDOM_MTK) += mtk-rng.o
|
|
obj-$(CONFIG_HW_RANDOM_CAVIUM) += cavium-rng.o cavium-rng-vf.o
|
|
--- a/drivers/crypto/Kconfig
|
|
+++ b/drivers/crypto/Kconfig
|
|
@@ -553,6 +553,24 @@ config CRYPTO_DEV_ROCKCHIP
|
|
This driver interfaces with the hardware crypto accelerator.
|
|
Supporting cbc/ecb chainmode, and aes/des/des3_ede cipher mode.
|
|
|
|
+config CRYPTO_DEV_MEDIATEK
|
|
+ tristate "MediaTek's EIP97 Cryptographic Engine driver"
|
|
+ depends on HAS_DMA
|
|
+ depends on (ARM && ARCH_MEDIATEK) || COMPILE_TEST
|
|
+ select CRYPTO_AES
|
|
+ select CRYPTO_AEAD
|
|
+ select CRYPTO_BLKCIPHER
|
|
+ select CRYPTO_CTR
|
|
+ select CRYPTO_SHA1
|
|
+ select CRYPTO_SHA256
|
|
+ select CRYPTO_SHA512
|
|
+ select CRYPTO_HMAC
|
|
+ help
|
|
+ This driver allows you to utilize the hardware crypto accelerator
|
|
+ EIP97 which can be found on the MT7623 MT2701, MT8521p, etc ....
|
|
+ Select this if you want to use it for AES/SHA1/SHA2 algorithms.
|
|
+
|
|
+
|
|
source "drivers/crypto/chelsio/Kconfig"
|
|
|
|
endif # CRYPTO_HW
|
|
--- a/drivers/crypto/Makefile
|
|
+++ b/drivers/crypto/Makefile
|
|
@@ -10,6 +10,7 @@ obj-$(CONFIG_CRYPTO_DEV_IMGTEC_HASH) +=
|
|
obj-$(CONFIG_CRYPTO_DEV_IXP4XX) += ixp4xx_crypto.o
|
|
obj-$(CONFIG_CRYPTO_DEV_MV_CESA) += mv_cesa.o
|
|
obj-$(CONFIG_CRYPTO_DEV_MARVELL_CESA) += marvell/
|
|
+obj-$(CONFIG_CRYPTO_DEV_MEDIATEK) += mediatek/
|
|
obj-$(CONFIG_CRYPTO_DEV_MXS_DCP) += mxs-dcp.o
|
|
obj-$(CONFIG_CRYPTO_DEV_NIAGARA2) += n2_crypto.o
|
|
n2_crypto-y := n2_core.o n2_asm.o
|