48d9137d31
During certificate verification, OpenSSL (starting from version 1.0.1n and 1.0.2b) will attempt to find an alternative certificate chain if the first attempt to build such a chain fails. An error in the implementation of this logic can mean that an attacker could cause certain checks on untrusted certificates to be bypassed, such as the CA flag, enabling them to use a valid leaf certificate to act as a CA and "issue" an invalid certificate. This issue will impact any application that verifies certificates including SSL/TLS/DTLS clients and SSL/TLS/DTLS servers using client authentication. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 46285
23 lines
789 B
Diff
23 lines
789 B
Diff
--- a/Makefile.org
|
|
+++ b/Makefile.org
|
|
@@ -185,7 +185,7 @@ WTARFILE= $(NAME)-win.tar
|
|
EXHEADER= e_os2.h
|
|
HEADER= e_os.h
|
|
|
|
-all: Makefile build_all
|
|
+all: build_all
|
|
|
|
# as we stick to -e, CLEARENV ensures that local variables in lower
|
|
# Makefiles remain local and variable. $${VAR+VAR} is tribute to Korn
|
|
@@ -399,11 +399,6 @@ openssl.pc: Makefile
|
|
echo 'Version: '$(VERSION); \
|
|
echo 'Requires: libssl libcrypto' ) > openssl.pc
|
|
|
|
-Makefile: Makefile.org Configure config
|
|
- @echo "Makefile is older than Makefile.org, Configure or config."
|
|
- @echo "Reconfigure the source tree (via './config' or 'perl Configure'), please."
|
|
- @false
|
|
-
|
|
libclean:
|
|
rm -f *.map *.so *.so.* *.dylib *.dll engines/*.so engines/*.dll engines/*.dylib *.a engines/*.a */lib */*/lib
|
|
|