2d02a4f5bd
Refresh patches. Adapt 704-phy-no-genphy-soft-reset.patch. Remove brcm2708/950-0005-mm-Remove-the-PFN-busy-warning.patch. Compile-tested on brcm2708/bcm2708 and x86/64. Runtime-tested on brcm2708/bcm2708 and x86/64. Fixes the following vulnerabilities: - CVE-2017-7533 - CVE-2017-1000111 - CVE-2017-1000112 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
32 lines
903 B
Diff
32 lines
903 B
Diff
From: Gabor Juhos <juhosg@openwrt.org>
|
|
Subject: [PATCH] kernel/3.10: move squashfs check from rootfs split code into a separate file
|
|
|
|
lede-commit: d89bea92b31b4e157a0fa438e75370f089f73427
|
|
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|
---
|
|
drivers/mtd/Kconfig | 2 ++
|
|
drivers/mtd/Makefile | 2 ++
|
|
2 files changed, 4 insertions(+)
|
|
|
|
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -27,6 +27,8 @@ config MTD_SPLIT_FIRMWARE_NAME
|
|
depends on MTD_SPLIT_FIRMWARE
|
|
default "firmware"
|
|
|
|
+source "drivers/mtd/mtdsplit/Kconfig"
|
|
+
|
|
endmenu
|
|
|
|
config MTD_TESTS
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -6,6 +6,8 @@
|
|
obj-$(CONFIG_MTD) += mtd.o
|
|
mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
|
|
|
|
+obj-$(CONFIG_MTD_SPLIT) += mtdsplit/
|
|
+
|
|
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|