afc1675833
It is not needed for anything on the system and skipping this saves some build time, especially in cases where there is nothing to do. Signed-off-by: Felix Fietkau <nbd@nbd.name>
34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
Disable modules.order to improve build performance.
|
|
This file is not needed for anything in LEDE
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1193,7 +1193,6 @@ all: modules
|
|
|
|
PHONY += modules
|
|
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
|
|
- $(Q)$(AWK) '!x[$$0]++' $(vmlinux-dirs:%=$(objtree)/%/modules.order) > $(objtree)/modules.order
|
|
@$(kecho) ' Building modules, stage 2.';
|
|
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
|
|
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
|
|
@@ -1223,7 +1222,6 @@ _modinst_:
|
|
rm -f $(MODLIB)/build ; \
|
|
ln -s $(CURDIR) $(MODLIB)/build ; \
|
|
fi
|
|
- @cp -f $(objtree)/modules.order $(MODLIB)/
|
|
@cp -f $(objtree)/modules.builtin $(MODLIB)/
|
|
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modinst
|
|
|
|
--- a/scripts/Makefile.build
|
|
+++ b/scripts/Makefile.build
|
|
@@ -93,7 +93,7 @@ modorder-target := $(obj)/modules.order
|
|
# We keep a list of all modules in $(MODVERDIR)
|
|
|
|
__build: $(if $(KBUILD_BUILTIN),$(builtin-target) $(lib-target) $(extra-y)) \
|
|
- $(if $(KBUILD_MODULES),$(obj-m) $(modorder-target)) \
|
|
+ $(if $(KBUILD_MODULES),$(obj-m)) \
|
|
$(subdir-ym) $(always)
|
|
@:
|
|
|