b3f95490b9
This adds initial support for kernel 4.14 based on the patches for kernel 4.9. In the configuration I deactivated some of the new possible security features like: CONFIG_REFCOUNT_FULL CONFIG_SLAB_FREELIST_HARDENED CONFIG_SOFTLOCKUP_DETECTOR CONFIG_WARN_ALL_UNSEEDED_RANDOM And these overlay FS options are also deactivated: CONFIG_OVERLAY_FS_INDEX CONFIG_OVERLAY_FS_REDIRECT_DIR I activated this: CONFIG_FORTIFY_SOURCE CONFIG_POSIX_TIMERS CONFIG_SLAB_MERGE_DEFAULT CONFIG_WATCHDOG_HANDLE_BOOT_ENABLED I am not sure if I did the porting correct for the following patches: target/linux/generic/backport-4.14/020-backport_netfilter_rtcache.patch target/linux/generic/hack-4.14/220-gc_sections.patch target/linux/generic/hack-4.14/321-powerpc_crtsavres_prereq.patch target/linux/generic/pending-4.14/305-mips_module_reloc.patch target/linux/generic/pending-4.14/611-netfilter_match_bypass_default_table.patch target/linux/generic/pending-4.14/680-NET-skip-GRO-for-foreign-MAC-addresses.patch Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
46 lines
1.5 KiB
Diff
46 lines
1.5 KiB
Diff
From: Gabor Juhos <juhosg@openwrt.org>
|
|
Subject: usr: sanitize deps_initramfs list
|
|
|
|
If any filename in the intramfs dependency
|
|
list contains a colon, that causes a kernel
|
|
build error like this:
|
|
|
|
/devel/openwrt/build_dir/linux-ar71xx_generic/linux-3.6.6/usr/Makefile:58: *** multiple target patterns. Stop.
|
|
make[5]: *** [usr] Error 2
|
|
|
|
Fix it by removing such filenames from the
|
|
deps_initramfs list.
|
|
|
|
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|
---
|
|
usr/Makefile | 8 +++++---
|
|
1 file changed, 5 insertions(+), 3 deletions(-)
|
|
|
|
--- a/usr/Makefile
|
|
+++ b/usr/Makefile
|
|
@@ -39,20 +39,22 @@ ifneq ($(wildcard $(obj)/$(datafile_d_y)
|
|
include $(obj)/$(datafile_d_y)
|
|
endif
|
|
|
|
+deps_initramfs_sane := $(foreach v,$(deps_initramfs),$(if $(findstring :,$(v)),,$(v)))
|
|
+
|
|
quiet_cmd_initfs = GEN $@
|
|
cmd_initfs = $(initramfs) -o $@ $(ramfs-args) $(ramfs-input)
|
|
|
|
targets := $(datafile_y)
|
|
|
|
# do not try to update files included in initramfs
|
|
-$(deps_initramfs): ;
|
|
+$(deps_initramfs_sane): ;
|
|
|
|
-$(deps_initramfs): klibcdirs
|
|
+$(deps_initramfs_sane): klibcdirs
|
|
# We rebuild initramfs_data.cpio if:
|
|
# 1) Any included file is newer then initramfs_data.cpio
|
|
# 2) There are changes in which files are included (added or deleted)
|
|
# 3) If gen_init_cpio are newer than initramfs_data.cpio
|
|
# 4) arguments to gen_initramfs.sh changes
|
|
-$(obj)/$(datafile_y): $(obj)/gen_init_cpio $(deps_initramfs) klibcdirs
|
|
+$(obj)/$(datafile_y): $(obj)/gen_init_cpio $(deps_initramfs_sane) klibcdirs
|
|
$(Q)$(initramfs) -l $(ramfs-input) > $(obj)/$(datafile_d_y)
|
|
$(call if_changed,initfs)
|