3c1f6e358d
Patches are generated using the "format-patch" command from the following location: *https://www.codeaurora.org/cgit/quic/kernel/galak-msm/log/?h=apq_ipq_base *rev=0771849495b4128cac2faf7d49c85c729fc48b20 Patches numbered 76/77/102/103 have already been integrated in 3.14.12, so they're not in this list. All these patches are either integrated are pending integration into kernel.org, therefore these patches should go away once the kernel gets upgraded to 3.16. Support is currently limited to AP148 board but can be extended to other platforms in the future. These changes do not cover ethernet connectivity. Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org> SVN-Revision: 42334
55 lines
1.6 KiB
Diff
55 lines
1.6 KiB
Diff
From 776fff11c1bf57e564a386521e56c277287a568c Mon Sep 17 00:00:00 2001
|
|
From: Kumar Gala <galak@codeaurora.org>
|
|
Date: Thu, 8 May 2014 13:40:16 -0500
|
|
Subject: [PATCH 132/182] XXX: Add boot support for u-boot.ipq image
|
|
|
|
---
|
|
arch/arm/Makefile | 2 +-
|
|
arch/arm/boot/Makefile | 11 ++++++++++-
|
|
2 files changed, 11 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/arch/arm/Makefile b/arch/arm/Makefile
|
|
index 51e5bed..e9fc731 100644
|
|
--- a/arch/arm/Makefile
|
|
+++ b/arch/arm/Makefile
|
|
@@ -297,7 +297,7 @@ archprepare:
|
|
# Convert bzImage to zImage
|
|
bzImage: zImage
|
|
|
|
-BOOT_TARGETS = zImage Image xipImage bootpImage uImage
|
|
+BOOT_TARGETS = zImage Image xipImage bootpImage uImage uImage.ipq Image.gz
|
|
INSTALL_TARGETS = zinstall uinstall install
|
|
|
|
PHONY += bzImage $(BOOT_TARGETS) $(INSTALL_TARGETS)
|
|
diff --git a/arch/arm/boot/Makefile b/arch/arm/boot/Makefile
|
|
index ec2f806..3cbc83e 100644
|
|
--- a/arch/arm/boot/Makefile
|
|
+++ b/arch/arm/boot/Makefile
|
|
@@ -25,7 +25,7 @@ INITRD_PHYS := $(initrd_phys-y)
|
|
|
|
export ZRELADDR INITRD_PHYS PARAMS_PHYS
|
|
|
|
-targets := Image zImage xipImage bootpImage uImage
|
|
+targets := Image zImage xipImage bootpImage uImage uImage.ipq Image.gz
|
|
|
|
ifeq ($(CONFIG_XIP_KERNEL),y)
|
|
|
|
@@ -80,6 +80,15 @@ $(obj)/uImage: $(obj)/zImage FORCE
|
|
$(call if_changed,uimage)
|
|
@$(kecho) ' Image $@ is ready'
|
|
|
|
+$(obj)/uImage.ipq: $(obj)/Image.gz FORCE
|
|
+ @$(check_for_multiple_loadaddr)
|
|
+ $(call if_changed,uimage,gzip)
|
|
+ @$(kecho) ' Image $@ is ready'
|
|
+
|
|
+$(obj)/Image.gz: $(obj)/Image FORCE
|
|
+ $(call if_changed,gzip)
|
|
+ @$(kecho) ' Image $@ is ready'
|
|
+
|
|
$(obj)/bootp/bootp: $(obj)/zImage initrd FORCE
|
|
$(Q)$(MAKE) $(build)=$(obj)/bootp $@
|
|
@:
|
|
--
|
|
1.7.10.4
|
|
|