38519cad0b
The most significant change from the previous version is the trimming of the 300-ip_tiny.patch to lib/utils.c where a section previously patched had vanished. That section of the patch was removed. Built and lightly tested on ar71xx against uClibc and musl. Signed-off-by: Russell Senior <russell@personaltelco.net> SVN-Revision: 45512
11 lines
249 B
Diff
11 lines
249 B
Diff
--- a/lib/Makefile
|
|
+++ b/lib/Makefile
|
|
@@ -4,7 +4,7 @@ ifeq ($(IP_CONFIG_SETNS),y)
|
|
CFLAGS += -DHAVE_SETNS
|
|
endif
|
|
|
|
-CFLAGS += -fPIC
|
|
+CFLAGS += $(FPIC)
|
|
|
|
UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o \
|
|
names.o
|