863e79f8d5
The following patches were dropped because they are already applied upstream: 0012-pinctrl-lantiq-fix-up-pinmux.patch 0013-MTD-lantiq-xway-fix-invalid-operator.patch 0014-MTD-lantiq-xway-the-latched-command-should-be-persis.patch 0015-MTD-lantiq-xway-remove-endless-loop.patch 0016-MTD-lantiq-xway-add-missing-write_buf-and-read_buf-t.patch 0017-MTD-xway-fix-nand-locking.patch 0044-pinctrl-lantiq-introduce-new-dedicated-devicetree-bi.patch 0045-pinctrl-lantiq-Fix-GPIO-Setup-of-GPIO-Port3.patch 0046-pinctrl-lantiq-2-pins-have-the-wrong-mux-list.patch 0047-irq-fixes.patch 0047-mtd-plat-nand-pass-of-node.patch 0060-usb-dwc2-Add-support-for-Lantiq-ARX-and-XRX-SoCs.patch 0120-MIPS-lantiq-add-support-for-device-tree-file-from-bo.patch 0121-MIPS-lantiq-make-it-possible-to-build-in-no-device-t.patch 122-MIPS-store-the-appended-dtb-address-in-a-variable.patch The PHY driver was reduced to the code adding the LED configuration, the rest is already upstream: 0023-NET-PHY-adds-driver-for-lantiq-PHY11G.patch The SPI driver was replaced with the version pending for upstream inclusion: New driver: 0090-spi-add-transfer_status-callback.patch 0091-spi-lantiq-ssc-add-support-for-Lantiq-SSC-SPI-controller.patch Old driver: 0100-spi-add-support-for-Lantiq-SPI-controller.patch Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
170 lines
5.1 KiB
Diff
170 lines
5.1 KiB
Diff
--- /dev/null
|
|
+++ b/arch/mips/include/asm/mach-lantiq/vpe.h
|
|
@@ -0,0 +1,44 @@
|
|
+/*
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License as published by
|
|
+ * the Free Software Foundation; either version 2 of the License, or
|
|
+ * (at your option) any later version.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * You should have received a copy of the GNU General Public License
|
|
+ * along with this program; if not, write to the Free Software
|
|
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
|
|
+ *
|
|
+ * Copyright (C) 2005 infineon
|
|
+ * Copyright (C) 2007 John Crispin <blogic@openwrt.org>
|
|
+ *
|
|
+ */
|
|
+#ifndef _IFXMIPS_VPE_H__
|
|
+#define _IFXMIPS_VPE_H__
|
|
+
|
|
+/* For the explanation of the APIs please refer the section "MT APRP Kernel
|
|
+ * Programming" in AR9 SW Architecture Specification
|
|
+ */
|
|
+int32_t vpe1_sw_start(void* sw_start_addr, uint32_t tcmask, uint32_t flags);
|
|
+int32_t vpe1_sw_stop(uint32_t flags);
|
|
+uint32_t vpe1_get_load_addr (uint32_t flags);
|
|
+uint32_t vpe1_get_max_mem (uint32_t flags);
|
|
+
|
|
+int32_t vpe1_set_boot_param(char *field, char *value, char flags);
|
|
+int32_t vpe1_get_boot_param(char *field, char **value, char flags);
|
|
+
|
|
+/* Watchdog APIs */
|
|
+extern unsigned long vpe1_wdog_ctr;
|
|
+extern unsigned long vpe1_wdog_timeout;
|
|
+
|
|
+unsigned long vpe1_sw_wdog_start(unsigned long);
|
|
+unsigned long vpe1_sw_wdog_stop(unsigned long);
|
|
+
|
|
+typedef int (*VPE_SW_WDOG_RESET)(unsigned long wdog_cleared_ok_count);
|
|
+int32_t vpe1_sw_wdog_register_reset_handler(VPE_SW_WDOG_RESET reset_fn);
|
|
+
|
|
+#endif
|
|
--- /dev/null
|
|
+++ b/arch/mips/lantiq/softdog_vpe.c
|
|
@@ -0,0 +1,109 @@
|
|
+/*
|
|
+** =============================================================================
|
|
+** FILE NAME : softdog_vpe.c
|
|
+** MODULES : LXDB
|
|
+** DATE : 24-03-2008
|
|
+** AUTHOR : LXDB Team
|
|
+** DESCRIPTION : This header file contains the code for the watchdog
|
|
+** implentation on vpe1 side.
|
|
+** REFERENCES :
|
|
+** COPYRIGHT : Copyright (c) 2008
|
|
+** Am Campeon 1-12, 85579 Neubiberg, Germany
|
|
+** Any use of this software is subject to the conclusion of a respective
|
|
+** License agreement. Without such a License agreement no rights to the
|
|
+** software are granted
|
|
+**
|
|
+** HISTORY :
|
|
+** $Date $Author $Comment
|
|
+** 24-03-2008 LXDB Initial version
|
|
+** ============================================================================
|
|
+*/
|
|
+
|
|
+#include <linux/module.h>
|
|
+#include <linux/moduleparam.h>
|
|
+#include <linux/types.h>
|
|
+#include <linux/timer.h>
|
|
+#include <linux/reboot.h>
|
|
+#include <linux/init.h>
|
|
+#include <linux/jiffies.h>
|
|
+
|
|
+#include <vpe.h>
|
|
+
|
|
+static unsigned long last_wdog_value;
|
|
+static unsigned long vpe1_wdog_cleared;
|
|
+
|
|
+static unsigned long vpe1_wdog_dead;
|
|
+static void watchdog_vpe0_fire(unsigned long); /* Called when vpe0 timer expires */
|
|
+static void keep_alive_vpe0(unsigned long);
|
|
+VPE_SW_WDOG_RESET reset_local_fn;
|
|
+
|
|
+
|
|
+static struct timer_list watchdog_vpe0_ticktock =
|
|
+ TIMER_INITIALIZER(watchdog_vpe0_fire, 0, 0);
|
|
+
|
|
+static void watchdog_vpe0_fire (unsigned long flags)
|
|
+{
|
|
+ volatile unsigned long *wdog_ctr_value;
|
|
+ wdog_ctr_value = (void*)vpe1_wdog_ctr;
|
|
+ if (*wdog_ctr_value == last_wdog_value) { /* VPE1 watchdog expiry handling */
|
|
+ vpe1_sw_wdog_stop(flags);
|
|
+ vpe1_wdog_dead++;
|
|
+ printk(KERN_DEBUG "VPE1 watchdog reset handler called\n");
|
|
+ /* Call the reset handler function */
|
|
+ reset_local_fn(flags);
|
|
+ } else { /* Everything is OK on vpe1 side. Continue. */
|
|
+ last_wdog_value = *wdog_ctr_value;
|
|
+ vpe1_wdog_cleared++;
|
|
+ keep_alive_vpe0(flags);
|
|
+ }
|
|
+}
|
|
+
|
|
+int32_t vpe1_sw_wdog_register_reset_handler (VPE_SW_WDOG_RESET reset_fn)
|
|
+{
|
|
+ reset_local_fn = (VPE_SW_WDOG_RESET)reset_fn;
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static void keep_alive_vpe0(unsigned long flags)
|
|
+{
|
|
+ mod_timer(&watchdog_vpe0_ticktock, jiffies+ vpe1_wdog_timeout );
|
|
+}
|
|
+
|
|
+unsigned long vpe1_sw_wdog_start(unsigned long flags)
|
|
+{
|
|
+ volatile unsigned long *wdog_ctr_value;
|
|
+ wdog_ctr_value = (void*)vpe1_wdog_ctr;
|
|
+ *wdog_ctr_value = 0;
|
|
+ last_wdog_value = 0;
|
|
+ keep_alive_vpe0(flags);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+unsigned long vpe1_sw_wdog_stop(unsigned long flags)
|
|
+{
|
|
+ del_timer(&watchdog_vpe0_ticktock);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int __init watchdog_vpe1_init(void)
|
|
+{
|
|
+ /* Nothing to be done here */
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static void __exit watchdog_vpe1_exit(void)
|
|
+{
|
|
+ unsigned long flags=0;
|
|
+ vpe1_sw_wdog_stop(flags);
|
|
+}
|
|
+
|
|
+module_init(watchdog_vpe1_init);
|
|
+module_exit(watchdog_vpe1_exit);
|
|
+
|
|
+EXPORT_SYMBOL(vpe1_sw_wdog_register_reset_handler);
|
|
+EXPORT_SYMBOL(vpe1_sw_wdog_start);
|
|
+EXPORT_SYMBOL(vpe1_sw_wdog_stop);
|
|
+
|
|
+MODULE_AUTHOR("LXDB");
|
|
+MODULE_DESCRIPTION("Software Watchdog For VPE1");
|
|
+MODULE_LICENSE("GPL");
|
|
--- a/arch/mips/lantiq/Makefile
|
|
+++ b/arch/mips/lantiq/Makefile
|
|
@@ -6,6 +6,8 @@
|
|
|
|
obj-y := irq.o clk.o prom.o
|
|
|
|
+obj-$(CONFIG_MIPS_VPE_LOADER) += softdog_vpe.o
|
|
+
|
|
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
|
|
|
|
obj-$(CONFIG_SOC_TYPE_XWAY) += xway/
|