openwrtv4/target/linux/adm5120/patches/103-mtd_trxsplit.patch
Gabor Juhos aaaa8b73a8 refresh patches
SVN-Revision: 10644
2008-03-22 15:36:37 +00:00

28 lines
1,000 B
Diff

Index: linux-2.6.24.2/drivers/mtd/Kconfig
===================================================================
--- linux-2.6.24.2.orig/drivers/mtd/Kconfig
+++ linux-2.6.24.2/drivers/mtd/Kconfig
@@ -57,6 +57,11 @@ config MTD_ROOTFS_SPLIT
depends on MTD_PARTITIONS
default y
+config MTD_TRXSPLIT
+ bool "Automatically find and split TRX partitions"
+ depends on MTD_PARTITIONS
+ default n
+
config MTD_REDBOOT_PARTS
tristate "RedBoot partition table parsing"
depends on MTD_PARTITIONS
Index: linux-2.6.24.2/drivers/mtd/Makefile
===================================================================
--- linux-2.6.24.2.orig/drivers/mtd/Makefile
+++ linux-2.6.24.2/drivers/mtd/Makefile
@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
+obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o