3256194aff
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 44922
29 lines
1.1 KiB
Diff
29 lines
1.1 KiB
Diff
Index: linux-4.0-rc4/drivers/clocksource/Kconfig
|
|
===================================================================
|
|
--- linux-4.0-rc4.orig/drivers/clocksource/Kconfig
|
|
+++ linux-4.0-rc4/drivers/clocksource/Kconfig
|
|
@@ -172,6 +172,12 @@ config VF_PIT_TIMER
|
|
help
|
|
Support for Period Interrupt Timer on Freescale Vybrid Family SoCs.
|
|
|
|
+config CLKSRC_RPS_TIMER
|
|
+ def_bool y if ARCH_OXNAS
|
|
+ select CLKSRC_MMIO
|
|
+ help
|
|
+ This option enables support for the oxnas rps timers.
|
|
+
|
|
config SYS_SUPPORTS_SH_CMT
|
|
bool
|
|
|
|
Index: linux-4.0-rc4/drivers/clocksource/Makefile
|
|
===================================================================
|
|
--- linux-4.0-rc4.orig/drivers/clocksource/Makefile
|
|
+++ linux-4.0-rc4/drivers/clocksource/Makefile
|
|
@@ -38,6 +38,7 @@ obj-$(CONFIG_CLKSRC_EFM32) += time-efm32
|
|
obj-$(CONFIG_CLKSRC_EXYNOS_MCT) += exynos_mct.o
|
|
obj-$(CONFIG_CLKSRC_SAMSUNG_PWM) += samsung_pwm_timer.o
|
|
obj-$(CONFIG_FSL_FTM_TIMER) += fsl_ftm_timer.o
|
|
+obj-$(CONFIG_CLKSRC_RPS_TIMER) += oxnas_rps_timer.o
|
|
obj-$(CONFIG_VF_PIT_TIMER) += vf_pit_timer.o
|
|
obj-$(CONFIG_CLKSRC_QCOM) += qcom-timer.o
|
|
obj-$(CONFIG_MTK_TIMER) += mtk_timer.o
|