9aa196e0f2
Refresh patches, following required reworking: ar71xx/patches-4.9/930-chipidea-pullup.patch layerscape/patches-4.9/302-dts-support-layercape.patch sunxi/patches-4.9/0052-stmmac-form-4-12.patch Fixes for CVEs: CVE-2018-1108 CVE-2018-1092 Tested on: ar71xx Archer C7 v2 Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> Tested-by: Koen Vandeputte <koen.vandeputte@ncentric.com> Tested-by: Arjen de Korte <build+openwrt@de-korte.org>
24 lines
814 B
Diff
24 lines
814 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -768,6 +768,11 @@ config SPI_RB4XX_CPLD
|
|
SPI driver for the Xilinx CPLD chip present on the
|
|
MikroTik RB4xx boards.
|
|
|
|
+config SPI_VSC7385
|
|
+ tristate "Vitesse VSC7385 ethernet switch driver"
|
|
+ help
|
|
+ SPI driver for the Vitesse VSC7385 ethernet switch.
|
|
+
|
|
#
|
|
# Add new SPI protocol masters in alphabetical order above this line
|
|
#
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -99,6 +99,7 @@ spi-thunderx-objs := spi-cavium.o spi-
|
|
obj-$(CONFIG_SPI_THUNDERX) += spi-thunderx.o
|
|
obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-topcliff-pch.o
|
|
obj-$(CONFIG_SPI_TXX9) += spi-txx9.o
|
|
+obj-$(CONFIG_SPI_VSC7385) += spi-vsc7385.o
|
|
obj-$(CONFIG_SPI_XCOMM) += spi-xcomm.o
|
|
obj-$(CONFIG_SPI_XILINX) += spi-xilinx.o
|
|
obj-$(CONFIG_SPI_XLP) += spi-xlp.o
|