2d02a4f5bd
Refresh patches. Adapt 704-phy-no-genphy-soft-reset.patch. Remove brcm2708/950-0005-mm-Remove-the-PFN-busy-warning.patch. Compile-tested on brcm2708/bcm2708 and x86/64. Runtime-tested on brcm2708/bcm2708 and x86/64. Fixes the following vulnerabilities: - CVE-2017-7533 - CVE-2017-1000111 - CVE-2017-1000112 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
47 lines
1.7 KiB
Diff
47 lines
1.7 KiB
Diff
From: Gabor Juhos <juhosg@openwrt.org>
|
|
Subject: usr: sanitize deps_initramfs list
|
|
|
|
If any filename in the intramfs dependency
|
|
list contains a colon, that causes a kernel
|
|
build error like this:
|
|
|
|
/devel/openwrt/build_dir/linux-ar71xx_generic/linux-3.6.6/usr/Makefile:58: *** multiple target patterns. Stop.
|
|
make[5]: *** [usr] Error 2
|
|
|
|
Fix it by removing such filenames from the
|
|
deps_initramfs list.
|
|
|
|
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|
---
|
|
usr/Makefile | 8 +++++---
|
|
1 file changed, 5 insertions(+), 3 deletions(-)
|
|
|
|
--- a/usr/Makefile
|
|
+++ b/usr/Makefile
|
|
@@ -53,6 +53,8 @@ ifneq ($(wildcard $(obj)/.initramfs_data
|
|
include $(obj)/.initramfs_data.cpio.d
|
|
endif
|
|
|
|
+deps_initramfs_sane := $(foreach v,$(deps_initramfs),$(if $(findstring :,$(v)),,$(v)))
|
|
+
|
|
quiet_cmd_initfs = GEN $@
|
|
cmd_initfs = $(initramfs) -o $@ $(ramfs-args) $(ramfs-input)
|
|
|
|
@@ -61,14 +63,14 @@ targets := initramfs_data.cpio.gz initra
|
|
initramfs_data.cpio.lzo initramfs_data.cpio.lz4 \
|
|
initramfs_data.cpio
|
|
# do not try to update files included in initramfs
|
|
-$(deps_initramfs): ;
|
|
+$(deps_initramfs_sane): ;
|
|
|
|
-$(deps_initramfs): klibcdirs
|
|
+$(deps_initramfs_sane): klibcdirs
|
|
# We rebuild initramfs_data.cpio if:
|
|
# 1) Any included file is newer then initramfs_data.cpio
|
|
# 2) There are changes in which files are included (added or deleted)
|
|
# 3) If gen_init_cpio are newer than initramfs_data.cpio
|
|
# 4) arguments to gen_initramfs.sh changes
|
|
-$(obj)/initramfs_data.cpio$(suffix_y): $(obj)/gen_init_cpio $(deps_initramfs) klibcdirs
|
|
+$(obj)/initramfs_data.cpio$(suffix_y): $(obj)/gen_init_cpio $(deps_initramfs_sane) klibcdirs
|
|
$(Q)$(initramfs) -l $(ramfs-input) > $(obj)/.initramfs_data.cpio.d
|
|
$(call if_changed,initfs)
|