bb83c9dcca
Delete a bunch of fixes that are already included. Refresh patches. Compile-tested on malta/mipsel Runtime-tested on malta/mipsel Signed-off-by: Florian Fainelli <f.fainelli@gmail.com> Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
14 lines
522 B
Diff
14 lines
522 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -618,9 +618,9 @@ KBUILD_CFLAGS += $(call cc-option,-fno-P
|
|
KBUILD_AFLAGS += $(call cc-option,-fno-PIE)
|
|
|
|
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
|
-KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
|
|
+KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION) $(call cc-disable-warning,maybe-uninitialized,)
|
|
else
|
|
-KBUILD_CFLAGS += -O2
|
|
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
|
|
endif
|
|
|
|
# Tell gcc to never replace conditional load with a non-conditional one
|