652ac2c6fd
- fix compilation w. Kernel 4.6 due to hash->shash crypto API - remove a patch integrated upstream - remove unrecognized configure option removed upstream in 2010 commit 40d0345f1ed02de183b13a6ce38847bc1f4ac48e Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
11 lines
433 B
Diff
11 lines
433 B
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
|
|
|
|
if test -n "$kbuilddir"; then
|
|
AC_MSG_CHECKING([kernel version that we will build against])
|
|
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
|
|
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
|
|
save_IFS="$IFS"
|
|
IFS='.'
|
|
set x $krel
|