4270847a2c
Some ath10k firmware versions allow to access the chip internal a temperature sensor and allow to reduce the amount of the time when the card is allowed to send. The latter is required on devices which tend to overheat. An userspace service has to read /sys/class/ieee80211/phy*/device/hwmon/hwmon*/temp1_input regularly and then decide how much the device has to be throttled. This can be done by writing to /sys/class/ieee80211/phy*/device/cooling_device/cur_state. By default it is not throttled (0) but it can be throttled up to 100(%). Signed-off-by: Sven Eckelmann <sven.eckelmann@openmesh.com>
91 lines
3.2 KiB
Diff
91 lines
3.2 KiB
Diff
From 42e01cb9cb109fb0bb4743f6c54d6aa67ac39b61 Mon Sep 17 00:00:00 2001
|
|
Message-Id: <42e01cb9cb109fb0bb4743f6c54d6aa67ac39b61.1515610034.git.mschiffer@universe-factory.net>
|
|
In-Reply-To: <9df7ddc3ed25b7d3473f117a0680b9418adb5753.1515610034.git.mschiffer@universe-factory.net>
|
|
References: <9df7ddc3ed25b7d3473f117a0680b9418adb5753.1515610034.git.mschiffer@universe-factory.net>
|
|
From: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Date: Mon, 27 Nov 2017 18:56:23 +0100
|
|
Subject: [PATCH 2/2] ath10k: move spectral scan support under a separate
|
|
config symbol
|
|
|
|
At the moment, spectral scan support, and with it RELAY, is always enabled
|
|
with ATH10K_DEBUGFS. Spectral scan support is currently the only user of
|
|
RELAY in ath10k, and it unconditionally reserves a relay channel.
|
|
|
|
Having debugfs support in ath10k is often useful even on very small
|
|
embedded routers, where we'd rather like to avoid the code size and RAM
|
|
usage of the relay support. While ath10k-based devices usually have more
|
|
resources than ath9k-based ones, it makes sense to keep the configuration
|
|
symmetric to ath9k, so the same base kernel without RELAY can be used for
|
|
both ath9k and ath10k hardware.
|
|
|
|
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Signed-off-by: Kalle Valo <kvalo@qca.qualcomm.com>
|
|
---
|
|
drivers/net/wireless/ath/ath10k/Kconfig | 9 ++++++++-
|
|
drivers/net/wireless/ath/ath10k/Makefile | 2 +-
|
|
drivers/net/wireless/ath/ath10k/spectral.h | 4 ++--
|
|
3 files changed, 11 insertions(+), 4 deletions(-)
|
|
|
|
--- a/drivers/net/wireless/ath/ath10k/Kconfig
|
|
+++ b/drivers/net/wireless/ath/ath10k/Kconfig
|
|
@@ -51,12 +51,19 @@ config ATH10K_DEBUG
|
|
config ATH10K_DEBUGFS
|
|
bool "Atheros ath10k debugfs support"
|
|
depends on ATH10K && DEBUG_FS
|
|
- depends on RELAY
|
|
---help---
|
|
Enabled debugfs support
|
|
|
|
If unsure, say Y to make it easier to debug problems.
|
|
|
|
+config ATH10K_SPECTRAL
|
|
+ bool "Atheros ath10k spectral scan support"
|
|
+ depends on ATH10K_DEBUGFS
|
|
+ depends on RELAY
|
|
+ default n
|
|
+ ---help---
|
|
+ Say Y to enable access to the FFT/spectral data via debugfs.
|
|
+
|
|
config ATH10K_TRACING
|
|
depends on !KERNEL_3_4
|
|
bool "Atheros ath10k tracing support"
|
|
--- a/drivers/net/wireless/ath/ath10k/Makefile
|
|
+++ b/drivers/net/wireless/ath/ath10k/Makefile
|
|
@@ -14,7 +14,7 @@ ath10k_core-y += mac.o \
|
|
p2p.o \
|
|
swap.o
|
|
|
|
-ath10k_core-$(CPTCFG_ATH10K_DEBUGFS) += spectral.o
|
|
+ath10k_core-$(CPTCFG_ATH10K_SPECTRAL) += spectral.o
|
|
ath10k_core-$(CPTCFG_NL80211_TESTMODE) += testmode.o
|
|
ath10k_core-$(CPTCFG_ATH10K_TRACING) += trace.o
|
|
ath10k_core-$(CPTCFG_ATH10K_THERMAL) += thermal.o
|
|
--- a/drivers/net/wireless/ath/ath10k/spectral.h
|
|
+++ b/drivers/net/wireless/ath/ath10k/spectral.h
|
|
@@ -44,7 +44,7 @@ enum ath10k_spectral_mode {
|
|
SPECTRAL_MANUAL,
|
|
};
|
|
|
|
-#ifdef CPTCFG_ATH10K_DEBUGFS
|
|
+#ifdef CPTCFG_ATH10K_SPECTRAL
|
|
|
|
int ath10k_spectral_process_fft(struct ath10k *ar,
|
|
struct wmi_phyerr_ev_arg *phyerr,
|
|
@@ -85,6 +85,6 @@ static inline void ath10k_spectral_destr
|
|
{
|
|
}
|
|
|
|
-#endif /* CPTCFG_ATH10K_DEBUGFS */
|
|
+#endif /* CPTCFG_ATH10K_SPECTRAL */
|
|
|
|
#endif /* SPECTRAL_H */
|
|
--- a/local-symbols
|
|
+++ b/local-symbols
|
|
@@ -140,6 +140,7 @@ ATH10K_SDIO=
|
|
ATH10K_USB=
|
|
ATH10K_DEBUG=
|
|
ATH10K_DEBUGFS=
|
|
+ATH10K_SPECTRAL=
|
|
ATH10K_THERMAL=
|
|
ATH10K_TRACING=
|
|
ATH10K_DFS_CERTIFIED=
|