openwrtv4/target/linux/adm5120/patches/003-adm5120_switch.patch
Gabor Juhos db4cd8515c refresh patches to match upstream style
SVN-Revision: 11374
2008-06-06 08:54:13 +00:00

23 lines
667 B
Diff

--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
@@ -601,6 +601,10 @@
If you have an Alchemy Semi AU1X00 based system
say Y. Otherwise, say N.
+config MIPS_ADM5120_ENET
+ tristate "MIPS ADM5120 Ethernet switch support"
+ depends on MIPS_ADM5120
+
config SGI_IOC3_ETH
bool "SGI IOC3 Ethernet"
depends on PCI && SGI_IP27
--- a/drivers/net/Makefile
+++ b/drivers/net/Makefile
@@ -183,6 +183,7 @@
# This is also a 82596 and should probably be merged
obj-$(CONFIG_LP486E) += lp486e.o
+obj-$(CONFIG_MIPS_ADM5120_ENET) += adm5120sw.o
obj-$(CONFIG_ETH16I) += eth16i.o
obj-$(CONFIG_ZORRO8390) += zorro8390.o
obj-$(CONFIG_HPLANCE) += hplance.o 7990.o