7bbf4117c6
This add support for kernel 4.9 to the ar71xx target. It was compile tested with the generic, NAND and mikrotik subtarget. Multiple members of the community tested it on their boards and did not report any major problem so far. Especially the NAND part received some changes to adapt to the new kernel APIs. The serial driver hack used for the Arduino Yun was not ported because the kernel changed there a lot. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
25 lines
957 B
Diff
25 lines
957 B
Diff
--- a/drivers/mtd/nand/Kconfig
|
|
+++ b/drivers/mtd/nand/Kconfig
|
|
@@ -577,4 +577,12 @@ config MTD_NAND_RB750
|
|
tristate "NAND flash driver for the RouterBoard 750"
|
|
depends on MTD_NAND && ATH79_MACH_RB750
|
|
|
|
+config MTD_NAND_AR934X
|
|
+ tristate "NAND flash driver for the Qualcomm Atheros AR934x/QCA955x SoCs"
|
|
+ depends on (SOC_AR934X || SOC_QCA955X)
|
|
+
|
|
+config MTD_NAND_AR934X_HW_ECC
|
|
+ bool "Hardware ECC support for the AR934X NAND Controller (EXPERIMENTAL)"
|
|
+ depends on MTD_NAND_AR934X
|
|
+
|
|
endif # MTD_NAND
|
|
--- a/drivers/mtd/nand/Makefile
|
|
+++ b/drivers/mtd/nand/Makefile
|
|
@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-
|
|
obj-$(CONFIG_MTD_NAND_DENALI) += denali.o
|
|
obj-$(CONFIG_MTD_NAND_DENALI_PCI) += denali_pci.o
|
|
obj-$(CONFIG_MTD_NAND_DENALI_DT) += denali_dt.o
|
|
+obj-$(CONFIG_MTD_NAND_AR934X) += ar934x_nfc.o
|
|
obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o
|
|
obj-$(CONFIG_MTD_NAND_BF5XX) += bf5xx_nand.o
|
|
obj-$(CONFIG_MTD_NAND_S3C2410) += s3c2410.o
|