f791fb4af4
Signed-off-by: Felix Fietkau <nbd@nbd.name> Signed-off-by: Tim Harvey <tharvey@gateworks.com> [fixes]
79 lines
2.1 KiB
Diff
79 lines
2.1 KiB
Diff
--- a/net/rfkill/Kconfig
|
|
+++ b/net/rfkill/Kconfig
|
|
@@ -1,7 +1,11 @@
|
|
#
|
|
# RF switch subsystem configuration
|
|
#
|
|
-menuconfig RFKILL
|
|
+config RFKILL
|
|
+ bool
|
|
+ default y
|
|
+
|
|
+menuconfig RFKILL_FULL
|
|
tristate "RF switch subsystem support"
|
|
help
|
|
Say Y here if you want to have control over RF switches
|
|
@@ -13,19 +17,19 @@ menuconfig RFKILL
|
|
# LED trigger support
|
|
config RFKILL_LEDS
|
|
bool
|
|
- depends on RFKILL
|
|
+ depends on RFKILL_FULL
|
|
depends on LEDS_TRIGGERS = y || RFKILL = LEDS_TRIGGERS
|
|
default y
|
|
|
|
config RFKILL_INPUT
|
|
bool "RF switch input support" if EXPERT
|
|
- depends on RFKILL
|
|
+ depends on RFKILL_FULL
|
|
depends on INPUT = y || RFKILL = INPUT
|
|
default y if !EXPERT
|
|
|
|
config RFKILL_REGULATOR
|
|
tristate "Generic rfkill regulator driver"
|
|
- depends on RFKILL || !RFKILL
|
|
+ depends on RFKILL_FULL || !RFKILL_FULL
|
|
depends on REGULATOR
|
|
help
|
|
This options enable controlling radio transmitters connected to
|
|
@@ -36,7 +40,7 @@ config RFKILL_REGULATOR
|
|
|
|
config RFKILL_GPIO
|
|
tristate "GPIO RFKILL driver"
|
|
- depends on RFKILL
|
|
+ depends on RFKILL_FULL
|
|
depends on GPIOLIB || COMPILE_TEST
|
|
default n
|
|
help
|
|
--- a/net/rfkill/Makefile
|
|
+++ b/net/rfkill/Makefile
|
|
@@ -4,6 +4,6 @@
|
|
|
|
rfkill-y += core.o
|
|
rfkill-$(CONFIG_RFKILL_INPUT) += input.o
|
|
-obj-$(CONFIG_RFKILL) += rfkill.o
|
|
+obj-$(CONFIG_RFKILL_FULL) += rfkill.o
|
|
obj-$(CONFIG_RFKILL_REGULATOR) += rfkill-regulator.o
|
|
obj-$(CONFIG_RFKILL_GPIO) += rfkill-gpio.o
|
|
--- a/net/Makefile
|
|
+++ b/net/Makefile
|
|
@@ -51,7 +51,7 @@ obj-$(CONFIG_MAC80211) += mac80211/
|
|
obj-$(CONFIG_TIPC) += tipc/
|
|
obj-$(CONFIG_NETLABEL) += netlabel/
|
|
obj-$(CONFIG_IUCV) += iucv/
|
|
-obj-$(CONFIG_RFKILL) += rfkill/
|
|
+obj-$(CONFIG_RFKILL_FULL) += rfkill/
|
|
obj-$(CONFIG_NET_9P) += 9p/
|
|
obj-$(CONFIG_CAIF) += caif/
|
|
ifneq ($(CONFIG_DCB),)
|
|
--- a/include/linux/rfkill.h
|
|
+++ b/include/linux/rfkill.h
|
|
@@ -64,7 +64,7 @@ struct rfkill_ops {
|
|
int (*set_block)(void *data, bool blocked);
|
|
};
|
|
|
|
-#if defined(CONFIG_RFKILL) || defined(CONFIG_RFKILL_MODULE)
|
|
+#if defined(CONFIG_RFKILL_FULL) || defined(CONFIG_RFKILL_FULL_MODULE)
|
|
/**
|
|
* rfkill_alloc - allocate rfkill structure
|
|
* @name: name of the struct -- the string is not copied internally
|