openwrtv4/package/madwifi/patches-testing/331-linux24_fix.patch
Felix Fietkau 9dc4917da8 rename patches-r3776 to patches-testing
SVN-Revision: 11868
2008-07-18 22:57:30 +00:00

15 lines
513 B
Diff

--- a/ath_hal/Makefile
+++ b/ath_hal/Makefile
@@ -79,10 +79,11 @@
quiet_cmd_uudecode = UUDECODE $@
cmd_uudecode = $(obj)/uudecode -o $@ $<
-$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
ifdef LINUX24
+$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
$(Q)$(obj)/uudecode -o $@ $<
else
+$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
$(call if_changed,uudecode)
endif
# Replace as many hashed names as possible with meaningful