openwrtv4/package/madwifi/patches-r3776/331-linux24_fix.patch
Felix Fietkau 16731f482f refresh madwifi-testing patches
SVN-Revision: 11866
2008-07-18 22:50:46 +00:00

15 lines
513 B
Diff

--- a/ath_hal/Makefile
+++ b/ath_hal/Makefile
@@ -79,10 +79,11 @@
quiet_cmd_uudecode = UUDECODE $@
cmd_uudecode = $(obj)/uudecode -o $@ $<
-$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
ifdef LINUX24
+$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
$(Q)$(obj)/uudecode -o $@ $<
else
+$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
$(call if_changed,uudecode)
endif
# Replace as many hashed names as possible with meaningful